Results 1 to 2 of 2
  1. #1
    New ROGer Array
    Join Date
    Apr 2020

    Post G731GU Random key presses

    Hey, I got Asus Rog Strix G731GU and few weeks ago while using it I spilled some vaping liquid on it. I tried to leave it for few days for it to completely dry off. When I started using it I didn't had any issues at all but like a week ago few buttons started to get randomly get pressed. After that I left it for some time again and now when I tried to use it, it got way worse, not only loads of buttons are being pressed to the point where I can't even log in but now it even turn on button is messed up. The liquid is rather thick so probably it didn't really all went out of there during that time. I tried to open it up and clean it as much as I could but I wasn't able to get too far. Is there any suggestions what else I could try out myself?

  2. #2
    TeamROG Moderator Array xeromist PC Specs
    xeromist PC Specs
    Laptop (Model)Intel NUC laptop LAPQC71D
    MotherboardROG Crosshair VIII Dark Hero
    ProcessorAMD 5800X
    Memory (part number)32GB G.Skill Ripjaws V 3600
    Graphics Card #1ROG Strix RTX3090Ti
    Sound CardSound Blaster Z
    MonitorAORUS FV43U
    Storage #1Samsung 970 Pro 512GB
    CPU CoolerCustom loop
    CaseBeQuiet Dark Base Pro 900 V2
    Power SupplyCorsair HX1000
    Keyboard ROG Strix Flare II Animate
    Mouse ROG Chakram X
    Headset Steelseries Arctis Pro Wireless
    Mouse Pad ROG Scabbard
    Headset/Speakers Logitech z906 5.1
    Network RouterpfSense/OPNsense
    xeromist's Avatar
    Join Date
    Jul 2010

    Not sure what will dissolve that. You could try rubbing alcohol or electronics cleaner.
    * Support disease research with Folding@Home *

    < < < Click the drop-down above my avatar for my PC specs!

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts