Results 1 to 3 of 3
  1. #1
    New ROGer Array
    Join Date
    May 2020
    Reputation
    10
    Posts
    1

    ROG zephyrus GA502 underperforming

    I just bought me and my wife matching ROG Zephyrus GA502's, open box at bestbuy one for 750 and one for 790. The problem is, my wife played subnautica, ran perfect, screen was flickering so we exchanged it, her new one will not play subnautica well at all. I downloaded it on mine and it works great. Ive updated all drivers, anyone have any idea what could be wrong?

  2. #2
    TeamROG Moderator Array xeromist PC Specs
    xeromist PC Specs
    Laptop (Model)Dell Inspiron 15 7567
    MotherboardMSI x470 Gaming Plus
    ProcessorAMD 2600X
    Memory (part number)16GB Crucial Ballistix Elite 3600
    Graphics Card #1ASUS GTX 1080 Strix
    MonitorBenQ BL3200PT
    Storage #1Intel 600p NVMe
    CPU CoolerWraith
    Casecustom Antec 900
    Power SupplyCorsair HX1000
    Keyboard Logitech Orion Spark
    Mouse Logitech MX500
    Headset Plantronics 777 with Oregon Aero upgrade
    xeromist's Avatar
    Join Date
    Jul 2010
    Reputation
    309
    Posts
    7,668

    Without more information it's impossible to tell. Could be overheating, component failure, software misconfiguration, power adapter not charging, etc.
    But if you have two machines and one doesn't work out of the box then I would return it if you can. You might be able to get it working but how much time do you want to spend when this should be the retailer or manufacturer's job?
    * Support disease research with Folding@Home *

    < < < Click the drop-down above my avatar for my PC specs!

  3. #3
    Super Moderator Array
    Join Date
    Jan 2013
    Reputation
    99
    Posts
    2,205

    Quote Originally Posted by Zer0j View Post
    I just bought me and my wife matching ROG Zephyrus GA502's, open box at bestbuy one for 750 and one for 790. The problem is, my wife played subnautica, ran perfect, screen was flickering so we exchanged it, her new one will not play subnautica well at all. I downloaded it on mine and it works great. Ive updated all drivers, anyone have any idea what could be wrong?
    You may also want to compare Windows 10 versions (search /run 'Winver' to see if you are running the latest Win10 v1909 which maybe you don't want to yet if your working unit isn't running it?) and check if any Windows updates are available (don't forget to restart Windows rather than shutdown and turn on the system again for software changes to take affect).

    Assuming you just want to get a better idea if there is some simple fix you can do, or if there is a hardware problem with the other unit, consider installing more games/programs on both systems to see if there are more problems on the bad unit, or there is an issue with just a single game which can hopefully be solved.

    You might also want to try to reset Windows on the problem unit especially if you don't have much on it yet that you're worried about and it didn't come in the 'Windows Welcome' condition when you received it.

    If you did any hardware/memory upgrades with the unit, consider that too.

    Feel free to request more ideas if necessary.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •