Results 1 to 2 of 2
  1. #1
    ROG Member Array
    Join Date
    Mar 2015
    Reputation
    10
    Posts
    24

    Display (XG279Q) flashes

    I recently got the ROG Strix XG279Q and it's been working great. However, there is this small anomaly I want to check whether or not it's normal behavior.

    Once in a while there are parts of the screen that flicker/flash white. Like a white band on a quadrant or half of the screen. Very briefly and rarely. When I say rarely it's like hours can go by without me noticing anything, and then maybe a get a couple of flashes within the next half hour or hour.

    Now, I don't mind it at all as long as it's normal and not a faulty display. Hence my question. Should I be concerned or just forget about it?

  2. #2
    ROG Member Array LordSabathan PC Specs
    LordSabathan PC Specs
    MotherboardAsus Maximus Code XI Z390
    ProcessorIntel 9900k
    Memory (part number)Corsair CMR32GX4M2C3000C15 2 x 16GB DDR4 3000 VENGEANCE RGB
    Graphics Card #1ASUS ROG STRIX GeForce RTX 2080 Ti O11G
    Sound CardAsus Strix Raid Pro
    MonitorAsus PG279Q
    Storage #1Samsung Evo 840 250GB
    Storage #2Samsung Evo 850 500GB
    CPU CoolerAsus Strix LC 360 RGB
    CaseAsus Strix Helios
    Power SupplyAsus Rog Thor 850w
    Keyboard Corsair K70 Rapidfire
    Mouse Asus Rog Gladius II Wireless
    Headset Corsair Virtuoso RGB
    Mouse Pad Asus Strix Edge,Asus Rog Balteus
    OS Windows 10 64bit Pro
    Network RouterAsus AC2900
    Accessory #1 Corsair ST100 RGB

    Join Date
    Jul 2016
    Reputation
    10
    Posts
    16

    I dont have this problem(same monitor), you should try differernt displayport cable and if not seems its monitor.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •