Results 1 to 2 of 2
  1. #1
    ROG Junior Member Array
    Join Date
    May 2017
    Reputation
    10
    Posts
    1

    Maximus X no longer recognizing USB keyboard at bios screen

    Hi, I recently updated the bios to allow me to use an Intel i9-9900k cpu and ever since, I cannot use my USB keyboard to enter the bios. The USB keyboard works fine once I pass the bios screen and enter Windows 10. I can use a wired keyboard for the bios and made sure to enable "Use legacy USB devices" but that didn't help. Does anyone have any suggestions? It really isn't a big deal, I just want to figure it out.

  2. #2
    New ROGer Array SiDeSaLaD PC Specs
    SiDeSaLaD PC Specs
    MotherboardROG Maximus XI Hero
    ProcessorIntel i9 9900KS @ 5.1 Ghz All Cores
    Memory (part number)Corsair Vengeance RGB PRO 32 GB DDR4 3200 @ 3600 (2x16GB)
    Graphics Card #1ASUS ROG Strix RTX 2080 Ti OC @ 1780Mhz
    MonitorSamsung LC34F791WQUXEN
    Storage #1Samsung SSD 970 Evo Plus 2TB
    Storage #2Seagate FireCuda 2 TB Hybrid
    CPU CoolerCorsair Hydro Series H150i PRO RGB
    CaseNZXT H700 - ATX Mid-Tower
    Power SupplyCorsair RM650X
    Keyboard Corsair K70 RGB MK.2 Mechanical
    Mouse Corsair Ironclaw RGB Optical
    Headset Sennheiser PC-350
    Headset/Speakers Logitech Z906 5.1 Surround Sound Speaker System
    OS Windows 10 Home 2004
    SiDeSaLaD's Avatar
    Join Date
    May 2020
    Reputation
    10
    Posts
    7

    Smile

    Hi

    Try switching EHCI Hand-off To Enabled, sometimes the Legacy USB also need ENABLED rather than AUTO
    If you are plugged into a USB 3 port you may also need to diable the xHCI

    Hope this helps

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •