Results 1 to 2 of 2
  1. #1
    New ROGer Array
    Join Date
    Sep 2019
    Reputation
    10
    Posts
    13

    still no fix for the GL504 fan?

    So people have been talking about the forum about this for months and why is there still no fix for it? about 4 months after i bought it i started having problems with the fan as it always was on at 7800RPM, even when the GPU is not in use, Asus employees told me that when it the temperature shows 0 degrees and 0 Mhz or when its showing weird numbers on your gpu temp/frq its not on. (i have an old android with the app which shows the fan speed and for some reason the application on the laptop does not show that) first when i start up the laptop the fan goes to 7800RPM even in battery saving mode, sometimes it goes to silent mode but after a while it randomly starts going up again. and when its at 7800RPM its loud and you must use headphones if you want to try to concentrate for work. and when i start up a game while plugged into socket in the fan goes to silent mode even when the gpu is at 90 degrees celcius. I already send it to a asus service location about 7 months ago but they told me that nothing was wrong with the fan and that its normal that the fan needs to do this even when the gpu is around 40-50 degrees celcius. i stopped using this laptop for work and just use if for games now and then but i really, really regret buying this laptop.

  2. #2
    Moderator Array
    Join Date
    Feb 2019
    Reputation
    10
    Posts
    213

    Hello ockie,
    May I have your complete model name? GL504GM, GL504GS....
    And may you double check if your BIOS and windows are both in latest version?
    https://www.asus.com/Laptops/ROG-Str...Desk_Download/
    Thank you.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •