Results 1 to 7 of 7
  1. #1
    New ROGer Array
    Join Date
    May 2020
    Reputation
    10
    Posts
    3

    G752VY Factory Image Request, Lost all Realtek sound enhancements.

    Hi there.

    Unfortunately the Samsung SM951 NVME drive died in my G752VY. I had backed up the factory image to an external drive which i can't find anymore (doh)

    I bought a new SSD, well, the same one. However none of the special settings for the Realtek HDA drivers work, I have no enhancements tab, no loudness equalisation, the jack detection doesn't work and neither do any of the settings in sonic suite 2. I assume it's because the RTKHDAUD.dat file has gone missing (it sits in C:\Windows\System32\drivers ) and this file tells the driver what it can unlock/enable. Just a note that this laptop uses HDA drivers, NOT UAD drivers.

    I did back up my Esupport folder and Have used that to re-install install everything, but no matter what version of driver, whether the esupport laptop one or newer. Nothing changes.

    I have asked ASUS UK for recovery media, they don't do it i basically got told "it's your own fault, f off" Essentially. However There is a place that ASUS USA redirects to to sell the factory image on USB stick. But, they dont ship outside of america. :/

    So, I'm in a bit of of a conundrum. If anyone on the forum has the same laptop I do, would you be willing to upload the factory image you made. For me to fix my laptop? And perhaps provide a RTKHDAUD.DAT file?

    I'm not sure if all VY series are the same, so. Mines a I7 6700HQ, 24GB of ram, 980M GTX 4gb Card. Gsync monitor. The 1 tb HDD and the SM951 SSD. With a Realtek ALC 668 sound chip.

    Thank you.

  2. #2
    ROG Member Array
    Join Date
    Dec 2017
    Reputation
    10
    Posts
    7

    Quote Originally Posted by FoxFoxFox View Post
    Hi there.

    Unfortunately the Samsung SM951 NVME drive died in my G752VY. I had backed up the factory image to an external drive which i can't find anymore (doh)

    I bought a new SSD, well, the same one. However none of the special settings for the Realtek HDA drivers work, I have no enhancements tab, no loudness equalisation, the jack detection doesn't work and neither do any of the settings in sonic suite 2. I assume it's because the RTKHDAUD.dat file has gone missing (it sits in C:\Windows\System32\drivers ) and this file tells the driver what it can unlock/enable. Just a note that this laptop uses HDA drivers, NOT UAD drivers.

    I did back up my Esupport folder and Have used that to re-install install everything, but no matter what version of driver, whether the esupport laptop one or newer. Nothing changes.

    I have asked ASUS UK for recovery media, they don't do it i basically got told "it's your own fault, f off" Essentially. However There is a place that ASUS USA redirects to to sell the factory image on USB stick. But, they dont ship outside of america. :/

    So, I'm in a bit of of a conundrum. If anyone on the forum has the same laptop I do, would you be willing to upload the factory image you made. For me to fix my laptop? And perhaps provide a RTKHDAUD.DAT file?

    I'm not sure if all VY series are the same, so. Mines a I7 6700HQ, 24GB of ram, 980M GTX 4gb Card. Gsync monitor. The 1 tb HDD and the SM951 SSD. With a Realtek ALC 668 sound chip.

    Thank you.

    Hi there,

    Sucks to hear about your SSD crashing

    For the sound drivers give this a view https://rog.asus.com/forum/showthrea...UAD-Notebooks)

    And if you go to your laptop support drivers page you should be able to find all the drivers needed for it.

  3. #3
    Moderator Array
    Join Date
    Feb 2019
    Reputation
    13
    Posts
    478

    Hello FoxFoxFox,
    Please refer to the official support page of your model.
    https://www.asus.com/ROG-Republic-Of...Desk_Download/
    Please kindly install the audio driver on it.
    May you provide more screenshot if it still not works?
    Also, about our service in UK, please kindly provide case ID for further escalation.
    Thank you.

  4. #4
    ROG Guru: Green Belt Array MoKiChU PC Specs
    MoKiChU PC Specs
    MotherboardASUS ROG Strix Z370-F Gaming
    ProcessorIntel Core i7-8700K
    Memory (part number)Corsair Vengeance RGB DDR4 2666MHz CL16 - 16GB (2 x 8GB)
    Graphics Card #1ASUS ROG Strix GTX 1080 Ti OC
    MonitorASUS ROG Strix XG35VQ
    Storage #1System : SSD Samsung 960 EVO 256GB
    Storage #2Games : SSD Corsair MP510 240GB | Data : SSHD Seagate 2TB
    CPU CoolerCooler Master ML240L RGB
    CaseBitFenix Enso
    Power SupplyCorsair TX850M (850W)
    Keyboard Logitech G413
    Mouse Logitech G502
    Mouse Pad PECHAM MPad-XXL
    Headset/Speakers Logitech Z333
    OS Windows 10 64 bit 20H2/VB/19042.x
    MoKiChU's Avatar
    Join Date
    Aug 2013
    Reputation
    254
    Posts
    502

    Quote Originally Posted by Setoka View Post
    For the sound drivers give this a view https://rog.asus.com/forum/showthrea...UAD-Notebooks)
    Hi,

    No, these UAD drivers will not work on his ROG SS2 notebook which requires HDA drivers.

    Here is the right thread for his notebook : https://rog.asus.com/forum/showthrea...HDA-Notebooks).

  5. #5
    New ROGer Array
    Join Date
    May 2020
    Reputation
    10
    Posts
    3

    Quote Originally Posted by Blake@ASUS View Post
    Hello FoxFoxFox,
    Please refer to the official support page of your model.
    https://www.asus.com/ROG-Republic-Of...Desk_Download/
    Please kindly install the audio driver on it.
    May you provide more screenshot if it still not works?
    Also, about our service in UK, please kindly provide case ID for further escalation.
    Thank you.

    Thank you for the reply Blake.
    Those are the drivers that are and have been installed many times, Both the newest and the older one as well as the ones in the esupport folder. I've also Tried @mokichu's drivers as well. I've uninstalled, reinstalled, wiped at least twenty or more times over the last several days

    I have tried three different windows 10 versions without any luck. The enhancements tab simply does not want to appear, nor will loudness equalisation work.

    Sure i'll show you some screenshots.

    As you c an see, i have no customisation options. No link to the SS2 functions from the Realtek control panel, nor any enhancements it provided.
    SS2 barely works, and also has no equalisation feature.

    Sound is unusable on my laptop, even with earphones it sounds bad. When i did have these options, the sound was fantastic with plenty of bass in my earphones and with the external speakers.

    I cannot RMA this laptop as ASUS UK/Europe wants nothing to do with it. i asked for a replacement disk/usb, they said "no we dont do that" All they'd said they would do is put the factory image on it for £200+ or more pounds plus shipping, They told me to just use "Live update" and thats it and put the phone down.

    I am not sure why it is so hard to provide a quality of life incase of things like this.
    Miniatura de Adjuntos Miniatura de Adjuntos Screenshot_13.jpg  

    Last edited by FoxFoxFox; 06-02-2020 at 06:22 AM.

  6. #6

  7. #7
    Moderator Array
    Join Date
    Feb 2019
    Reputation
    13
    Posts
    478

    Hello FoxFoxFox,
    Thank you for the detail.
    I have reported this issue.
    May you check the device manager,to see if there is any error message?
    Also, please provide the "Hardware Ids" of your audio device?
    (device manager> audio devices> properties>detail > Hardware Ids"

    I would like to apologize for our UK service.
    I'm really sorry that we currently do not provide recovery CD in most of the places in the world.
    Your opinion has been reported.
    Thank you very much.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •