Results 1 to 1 of 1
  1. #1
    New ROGer Array
    Join Date
    Nov 2019

    Armory Crate / Rog Service Crashing Access Violation Error

    A few days back, the armory crate app kept crashing and it kept flashing on the screen with the perfomance/ silent mode pop up depending what app I was using. The screen brightness caused by the changing power mode (App vs win) would change the brightness of the screen. So I looked into it.
    As it was already broke I uninstalled Armory Crate and the ROG live services and installed them fresh from the My Asus downloads. This did not work. After some attempts. I've tried to uninstall them and the traces using Revo and this keeps leaving me with the crashes.

    I have the log below. I have tried a rest (keeping personal files) of windows. I have a backup image of my files should a re-install of windows be in order.

    I also have dumps and the logs below. Looks like an access violation exception in the dll of aura service (possibly caused by the user session helper) I'm wondering if this is accessing a updated driver. As I had updates when all this happened.

    I've been struggling for some time puzzled and trying to work this out. I noticed the uninstaller for AC leaves traces so maybe there's something my eyes and revo didn't pick up.

    I was curious on one attempt and removed aura service .dll just to see what would happen. It moved onto the next dll in the files with another access violation message. I think if I reset and updated I would face this again due to it acessing memory used by a driver?

    I did thought I had fixed this once by installing the right visual studio C++ distro but this failed after a few moments


    Application: ArmouryCrate.UserSessionHelper.exe
    Framework Version: v4.0.30319
    Description: The process was terminated due to an unhandled exception.
    Exception Info: exception code c0000005, exception address 00007FFFD3DB532C

    Faulting application name: ArmouryCrate.UserSessionHelper.exe, version:, time stamp: 0x5e180de5
    Faulting module name: AuraPlugin.dll, version:, time stamp: 0x5e1eb849
    Exception code: 0xc0000005
    Fault offset: 0x000000000003532c
    Faulting process ID: 0x260c
    Faulting application start time: 0x01d647e506a5242e
    Faulting application path: C:\Program Files\ASUS\ARMOURY CRATE Service\ArmouryCrate.UserSessionHelper.exe
    Faulting module path: C:\Program Files\ASUS\ARMOURY CRATE Service\AuraPlugIn\AuraPlugin.dll
    Report ID: 67bfdfc5-1467-4340-96e6-5b525bc608c0
    Faulting package full name:
    Faulting package-relative application ID:
    Last edited by Jrg91; 06-21-2020 at 04:07 PM. Reason: Problem on site

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts