Results 1 to 4 of 4
  1. #1
    ROG Junior Member Array
    Join Date
    Sep 2018
    Reputation
    10
    Posts
    2

    PG43UQ flickering / issues

    I just got my PG43UQ with DSC.
    I have an RTX 2080ti hooked up using displayport at factory settings with DSC on and G-Sync on. Using it at Nvidia 4:4:4 10bit at 144 hz

    I'm getting a lot of flickering and brightness issues and poor text. No picture loss, but a lot of rapid dimming.
    Current settings:
    OD Lvl 4
    Dynamic Dimming off


    If this is just standard with this monitor i'm going to return it while I still can.

  2. #2
    New ROGer Array
    Join Date
    Feb 2020
    Reputation
    10
    Posts
    12

    Fellow PG43UQ and 2080 Ti guy here. The Level 1 Techs guide for the XG438Q also applies to this panel, so do that. This will make text as clear as possible.

    Make sure you have the latest Nvidia driver and either the included DisplayPort cable or another 8K-ready DP cable. One thing I ran into was the DisplayPort cable in the PG43UQ's DP 1, if also routed through the cable management clip, is bent so tight that it seems to cause signal loss and flickering on most cables. Watch out for that too.

  3. #3
    ROG Junior Member Array
    Join Date
    Sep 2018
    Reputation
    10
    Posts
    2

    Thanks for the reply -
    Definitely no bent cable and I'm using the latest Nvidia drivers.

    I'm not losing any picture ATM, but I'm seeing a lot of brightness rapid flashing changes. Like if I'm on the desktop or gaming, dark areas of the screen rapidly flash or have low clarity. I'm using the included DisplayPort 8k-ready cable.

    It is nice to be able to do RGB with 4k HDR 144hz, or 4:4:4 @ 10-bit, which my PG27UQ could not do, but it feels like these issues have made me take a major step backwards in reliability - especially if I'm looking at this to be the 'only' monitor I have for the next 3-5 years.

  4. #4
    ROG Enthusiast Array EXILE157 PC Specs
    EXILE157 PC Specs
    MotherboardROG Strix Z490-G Wi-Fi
    Processori9-10900K
    Memory (part number)Corsair Vengeance Pro RGB 64GB
    Graphics Card #1EVGA GeForce GTX 1080 Ti FTW3 Hybrid
    Sound CardCorsair ST100
    MonitorSharp Quattron
    Storage #1Samsung 970 Evo M.2 1TB
    Storage #2Samsung 840 Evo Series 1TB
    CPU CoolerNzxt Kraken Z63
    CaseLian Li PC-011 (Black)
    Power SupplyCorsair HX1200i
    Keyboard Corsair K70 RGB
    Mouse Corsair Dark Core
    Headset Razer Nari Ultimate
    Mouse Pad Corsair Gaming MM800 RGB
    OS Win10 Pro 64
    EXILE157's Avatar
    Join Date
    Jul 2014
    Reputation
    10
    Posts
    48

    Quote Originally Posted by austinrsmith View Post
    Thanks for the reply -
    Definitely no bent cable and I'm using the latest Nvidia drivers.

    I'm not losing any picture ATM, but I'm seeing a lot of brightness rapid flashing changes. Like if I'm on the desktop or gaming, dark areas of the screen rapidly flash or have low clarity. I'm using the included DisplayPort 8k-ready cable.

    It is nice to be able to do RGB with 4k HDR 144hz, or 4:4:4 @ 10-bit, which my PG27UQ could not do, but it feels like these issues have made me take a major step backwards in reliability - especially if I'm looking at this to be the 'only' monitor I have for the next 3-5 years.
    You should try another DP 1.4, go with Cable Matters 1.4 Cable. I've seen where Wendell from Level1Techs was having similar issues and he found out the included cable was part of the issue after he replaced it.
    *Lian Li PC-011D (Black) *i9-10900K *ROG Strix Z490-G *Nzxt Kraken Z63/Corsair QL Series *Corsair Vengeance Pro RGB 64GB (4x16GB) DDR4 *Corsair HX1200i *EVGA GeForce GTX 3080 Ultra FTW3 *Samsung 970 Evo M.2 1TB *Samsung 960 Evo M.2 500GB *Samsung 840 Evo Series 1TB SSD *Asus ROG Swift PG43UQ *Corsair K70 RGB *Corsair Dark Core *Corsair Gaming MM800 *Corsair ST100 *Razer Nari Ultimate.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •