Results 1 to 4 of 4
  1. #1
    ROG Junior Member Array
    Join Date
    Apr 2017
    Reputation
    10
    Posts
    2

    Zephyrus S GX701 RMA Repair Issues

    I bought a Zephyrus S GX701 with a RTX 2070 in early January of this year. It always ran hot, I’d see throttling across some CPU cores and CPU package temps peaking at 97C (CPU tjmax is 95C). But as the weather heated up the laptop just got worse. I was seeing CPU package temp hit 100C and throttling across all cores, which was causing noticeable impact in games.

    So I sent the laptop in to be repaired early June. Just got it back today and I cannot believe how terrible the repair job was. The RMA note said the motherboard was replaced, not sure why.

    First thing I did when I got the laptop this morning was install my aftermarket 16GB memory DIMM. I immediately noticed several screws were missing on the chassis, never a great sign.There was also some minor cosmetic damage in one corner, I assumed caused by incorrect use of a pry tool.

    On the inside things just got worse, the heatsink had a very bent and pinched CPU heat pipe. The heatsink no longer sits level on the CPU side. The tape for air flow guidance on the fans was missing on one side. The heat transfer foil at the top of the heatsink was half missing. The heatsink was also missing two screws.The WiFi cables were not run in the holders on the motherboard and one cable is frayed.

    After closing up the laptop and booting into Windows I’m welcomed by the left speaker making terrible noises. Oh, and a warning keeps popping up saying "The power connector is not plugged in properly. Please disconnect and reconnect the power adapter." Video of bad speaker https://youtu.be/8zZdk2KqM0Y

    TLDR, I got my laptop back from the ASUS service center in worse shape and with more problems than it had going in. For a laptop that retails for $2500 I expected more. Not sure what to do at this point. I’ve owned 5 ASUS laptops; this is the only one I’ve had thermal issues with or had such a terrible RMA experience.


    Click image for larger version. 

Name:	IMG-3056.jpg 
Views:	0 
Size:	685.7 KB 
ID:	85489
    Miniatura de Adjuntos Miniatura de Adjuntos IMG-3060.jpg  

    IMG-3063.jpg  


  2. #2
    ROG Junior Member Array
    Join Date
    Apr 2017
    Reputation
    10
    Posts
    2

    Finally got Apex Legends installed. After 5 minutes I am hitting 99C. Before the botched RMA it took 30-45min of CPU and GPU thermal load before it would hit that temp. Guess that's to be expected when I was seeing CPU temps hit 97C while just sitting on the desktop downloading the game. Laptop is pretty much a flame thrower now and mostly useless.



    Click image for larger version. 

Name:	Apex-5min.PNG 
Views:	0 
Size:	48.2 KB 
ID:	85492

  3. #3
    Moderator Array
    Join Date
    Feb 2019
    Reputation
    13
    Posts
    550

    Hello grarrg,
    I'm really sorry about this.
    Please kindly PM me your SN or RMA number (if you still kept the record)
    I have reported this related department.
    Thank you so mcuh!

  4. #4
    Moderator Array
    Join Date
    Jun 2018
    Reputation
    10
    Posts
    79

    Quote Originally Posted by grarrg View Post
    I bought a Zephyrus S GX701 with a RTX 2070 in early January of this year. It always ran hot, I’d see throttling across some CPU cores and CPU package temps peaking at 97C (CPU tjmax is 95C). But as the weather heated up the laptop just got worse. I was seeing CPU package temp hit 100C and throttling across all cores, which was causing noticeable impact in games.

    So I sent the laptop in to be repaired early June. Just got it back today and I cannot believe how terrible the repair job was. The RMA note said the motherboard was replaced, not sure why.

    First thing I did when I got the laptop this morning was install my aftermarket 16GB memory DIMM. I immediately noticed several screws were missing on the chassis, never a great sign.There was also some minor cosmetic damage in one corner, I assumed caused by incorrect use of a pry tool.

    On the inside things just got worse, the heatsink had a very bent and pinched CPU heat pipe. The heatsink no longer sits level on the CPU side. The tape for air flow guidance on the fans was missing on one side. The heat transfer foil at the top of the heatsink was half missing. The heatsink was also missing two screws.The WiFi cables were not run in the holders on the motherboard and one cable is frayed.

    After closing up the laptop and booting into Windows I’m welcomed by the left speaker making terrible noises. Oh, and a warning keeps popping up saying "The power connector is not plugged in properly. Please disconnect and reconnect the power adapter." Video of bad speaker https://youtu.be/8zZdk2KqM0Y

    TLDR, I got my laptop back from the ASUS service center in worse shape and with more problems than it had going in. For a laptop that retails for $2500 I expected more. Not sure what to do at this point. I’ve owned 5 ASUS laptops; this is the only one I’ve had thermal issues with or had such a terrible RMA experience.


    Click image for larger version. 

Name:	IMG-3056.jpg 
Views:	0 
Size:	685.7 KB 
ID:	85489
    Thank you for bringing this to our attention. My name is Adrian from the ASUS Customer Loyalty Team here at our North America Corporate Office. If you'd like, it'll be my pleasure to help straighten out your issue. Please email me with the below details so I can work with related personnel to get this straightened out.

    Product S/N:
    RMA #:
    Address:
    Full name:
    Phone#:
    Email:

    My email is cl-adrian@asus.com.:

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •