Results 1 to 5 of 5
  1. #1
    New ROGer Array
    Join Date
    Jul 2020
    Reputation
    10
    Posts
    2

    ROG Zephyrus GX501 unable to connect to 4k monitor at 60 hz via USB C Hub

    Hey guys!

    How can I connect my Zephyrus GX501 to a 4k monitor at 60 hz? When I connect the monitor via HDMI to HDMI, the monitor is identified but does not have anything displayed. When I plug in a typc C hub that can do max 4k 30hz, the monitor works. When I plug in a type C hub that ca do max 4k 60hz, nothing is displayed again. The monitor is 4k 60hz confirmed. I have reset the laptop, reinstalled the drivers numerous times, but nothing seems to work. The cable supports 4k at 60hz and so does the hdmi 2.0 ports. The monitor actually has a setting to adjust between hdmi 1.4 and 2.0, which is nice but even at 2.0 nothing happesn. Please shed some light!

    For some reason, when I open control panel, there the only graphics is the nvidia chip. The intel 630 HD does not show up (is it supposed to?).

    The laptop has gtx 1080 max q, i7-7700hq with 24gb ram and 512gb SSD.

    Thank you in advance.

  2. #2
    Moderator Array
    Join Date
    Feb 2019
    Reputation
    13
    Posts
    453

    Hello mengjuechen,
    May I know the brand and model of your monitor?
    And the complete model name ? GX501GI/VSK?
    Thank you.

  3. #3
    New ROGer Array
    Join Date
    Jul 2020
    Reputation
    10
    Posts
    2

    Hi Blake,

    Thanks for your reply.

    The laptop is a GX501- VIK and the monitor is a Samsung LU32R590CWNXZA 32" 4K UHD 60Hz Curved Monitor.

  4. #4
    Moderator Array
    Join Date
    Feb 2019
    Reputation
    13
    Posts
    453

    Hello mengjuechen,
    Thank you for your quick reply.
    I have reported this issue and am consulting for more information.
    Thank you.

  5. #5
    Moderator Array
    Join Date
    Feb 2019
    Reputation
    13
    Posts
    453

    Hello mengjuechen,
    Do you have another HDMI device you can link to? to see if the HDMI is really working?
    or you may change another HDMI cable.
    And for the USB-C hub, do you have another hub to cross check as well?
    Which brand and model if the hub?
    Thank you.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •