Results 1 to 4 of 4
  1. #1
    ROG Junior Member Array
    Join Date
    Apr 2017
    Reputation
    10
    Posts
    2

    Unable to submit RMA request

    It looks like the RMA request website is broken. I've also tried online chat but there are no available agents...

    Thank you for using the ASUS Online RMA feature.It looks like your serial number(SN:undefined)has already been issued an RMA.
    For your reference,the RMA number is undefined.You should have received the RMA instructions in a separate e-mail.Please allow up to 48
    hours for it to be sent out.

    How can I submit an RMA request for my broken AX58BT. It stopped working in less than 2 months

  2. #2
    Moderator Array
    Join Date
    Feb 2019
    Reputation
    13
    Posts
    442

    Hello darkkinz,
    I'm really sorry about this.
    There seems to be some technical issue with it, we have been trying to fix it.
    May you PM me your SN?

    Also, Please go to the website below and check for your RMA again.
    https://www.asus.com/us/support/repair-status-inquiry/
    Let me know if the RMA no. and status are showing or not.
    Thank you so much.

  3. #3
    ROG Junior Member Array
    Join Date
    Apr 2017
    Reputation
    10
    Posts
    2

    Quote Originally Posted by Blake@ASUS View Post
    Hello darkkinz,
    I'm really sorry about this.
    There seems to be some technical issue with it, we have been trying to fix it.
    May you PM me your SN?

    Also, Please go to the website below and check for your RMA again.
    https://www.asus.com/us/support/repair-status-inquiry/
    Let me know if the RMA no. and status are showing or not.
    Thank you so much.
    Sent you a PM

  4. #4
    Moderator Array
    Join Date
    Jun 2018
    Reputation
    10
    Posts
    71

    Quote Originally Posted by darkkinz View Post
    It looks like the RMA request website is broken. I've also tried online chat but there are no available agents...

    Thank you for using the ASUS Online RMA feature.It looks like your serial number(SN:undefined)has already been issued an RMA.
    For your reference,the RMA number is undefined.You should have received the RMA instructions in a separate e-mail.Please allow up to 48
    hours for it to be sent out.

    How can I submit an RMA request for my broken AX58BT. It stopped working in less than 2 months
    Hi darkkinz,

    My name is Adrian from the ASUS Customer Loyalty Team here at our North America Corporate Office. Please try running Windows Network Troubleshooter
    - To access the network troubleshooter, visit Settings > Network & Internet > Status. Select Network troubleshooter and follow the steps to see if Windows can rectify the problem. On Windows 7, you’ll find this same tool at Start > Control Panel > Troubleshooting > Network and internet > Network Connections.

    You can also try using Command Prompt (Admin)

    Try using these two commands:

    netsh winsock reset

    netsh int ip reset


    If that doesn't solve your issue please try these commands:

    ipconfig /release

    ipconfig /renew

    ipconfig /flushdns


    If all fails please email me the following:
    Product S/N:
    Address:
    Full name:
    Phone#:
    Email:

    My email is cl-adrian@asus.com.:

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •