Results 1 to 5 of 5
  1. #1
    New ROGer Array Silent84 PC Specs
    Silent84 PC Specs
    MotherboardAsus X570-F
    ProcessorRyzen 3600XT
    Memory (part number)Corsair Pro 16GB 3200MHz
    Graphics Card #1Palit 2080TI
    Monitor2xDell S2721HGF
    Storage #12xIntel 660p 512GB
    Storage #2Samsung 860 1TB
    CPU CoolerNZXT Kraken X62
    CasePHANTEKS ECLIPSE P600S Black
    Power SupplySeasonic PX 750 Platinum
    Keyboard Logitech G512 Carbon Tactile
    Mouse Logitech G502,Logitech G305
    Headset ASUS ROG Strix GO 2.4
    Mouse Pad HyperX Fury S Pro Speed Edition XL
    Headset/Speakers Logitech Z333

    Join Date
    Jul 2020
    Reputation
    10
    Posts
    20

    ROG Strix Go 2.4 random disconnect and reconnect in 3 sec

    Hi there, you have no clue when they do disconnect, but today they did more then 5 sec till they reconnected, i will never buy ASUS headsets again, very disappointed ! Stay away from this headset!
    I did talk with 4 youtubers(made reviews on them) and 2 friends, they all got this issues when the battery is low, like 50% or less they start to disconnect. Shame Asus, stop making headset, let other company to make them, Like Logitech or Corsair!
    Today they disconnect 3 times, i did yes install the last firmware, did try different port, front panel with usb3.0,3.1, and usb-C, it interesting that nobody from stuff is trying to help me or write something here, doesn't matter what you will say, just do IT, i did buy your headset for 175EURO, and i cant use them, it is very annoying, to play a game and get disconnect in the middle of a fight and people on discord is telling you, what is this buzzing noise men, when they disconnect they make a noise so load PLEASE realese a new firmware!
    Last edited by Silent84; 05-29-2021 at 10:59 AM. Reason: update

  2. #2
    New ROGer Array
    Join Date
    Dec 2020
    Reputation
    10
    Posts
    1

    i just found your post as trying to find out why mine is also doing this and sometimes the mic also turns off and i have to power off and on again

  3. #3
    New ROGer Array Silent84 PC Specs
    Silent84 PC Specs
    MotherboardAsus X570-F
    ProcessorRyzen 3600XT
    Memory (part number)Corsair Pro 16GB 3200MHz
    Graphics Card #1Palit 2080TI
    Monitor2xDell S2721HGF
    Storage #12xIntel 660p 512GB
    Storage #2Samsung 860 1TB
    CPU CoolerNZXT Kraken X62
    CasePHANTEKS ECLIPSE P600S Black
    Power SupplySeasonic PX 750 Platinum
    Keyboard Logitech G512 Carbon Tactile
    Mouse Logitech G502,Logitech G305
    Headset ASUS ROG Strix GO 2.4
    Mouse Pad HyperX Fury S Pro Speed Edition XL
    Headset/Speakers Logitech Z333

    Join Date
    Jul 2020
    Reputation
    10
    Posts
    20

    Quote Originally Posted by bigluke82 View Post
    i just found your post as trying to find out why mine is also doing this and sometimes the mic also turns off and i have to power off and on again
    hi there, sorry men to hear you got this issues, i know how you feel, i have another new headset asus strix go, and they do the same, but some dude from asus, said they will try to fix them, on end of june we get a new, update, lets hope they will fix it, there is nothing you can do, only with the new firmware, and use direct the dongle C, not the usb adapter, and use it in front of your case, not in the back, on your motherboard, they will disconnect more there, so if you got a case with port usb C will be nice!:

  4. #4
    New ROGer Array
    Join Date
    May 2021
    Reputation
    10
    Posts
    2

    Same here

    Just wanted to say that I have the same exact issue here, at first I though it might be the USB disconnect issue caused by AMD that's been fixed in AGESA 1.2.0.2 but I'm on the latest version of my motherboard (Asus Prime X570-Pro) and the issues is still present. I'm also using the latest version of the headset firmware (3763 as of this writing) this is kind of annoying because I've noticed that when it does that, the mic does not "reconnect" correctly.

    I'm using this headset for work and sometimes I have to "reset" (switch the headset on and off) for the mic to work properly because otherwise the other person i'm with on the phone does not hear me talk, that's quite annoying.

  5. #5
    New ROGer Array Silent84 PC Specs
    Silent84 PC Specs
    MotherboardAsus X570-F
    ProcessorRyzen 3600XT
    Memory (part number)Corsair Pro 16GB 3200MHz
    Graphics Card #1Palit 2080TI
    Monitor2xDell S2721HGF
    Storage #12xIntel 660p 512GB
    Storage #2Samsung 860 1TB
    CPU CoolerNZXT Kraken X62
    CasePHANTEKS ECLIPSE P600S Black
    Power SupplySeasonic PX 750 Platinum
    Keyboard Logitech G512 Carbon Tactile
    Mouse Logitech G502,Logitech G305
    Headset ASUS ROG Strix GO 2.4
    Mouse Pad HyperX Fury S Pro Speed Edition XL
    Headset/Speakers Logitech Z333

    Join Date
    Jul 2020
    Reputation
    10
    Posts
    20

    Quote Originally Posted by Z0simus View Post
    Just wanted to say that I have the same exact issue here, at first I though it might be the USB disconnect issue caused by AMD that's been fixed in AGESA 1.2.0.2 but I'm on the latest version of my motherboard (Asus Prime X570-Pro) and the issues is still present. I'm also using the latest version of the headset firmware (3763 as of this writing) this is kind of annoying because I've noticed that when it does that, the mic does not "reconnect" correctly.

    I'm using this headset for work and sometimes I have to "reset" (switch the headset on and off) for the mic to work properly because otherwise the other person i'm with on the phone does not hear me talk, that's quite annoying.
    Yep, it does that, sometimes makes a annoying noise on the mic, and people scream on me, get out from the discord, this headset is a waste of money, and all the firmware they do nothing, i have a feeling that, new firmware will not resolve the problem!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •