Results 1 to 2 of 2
  1. #1
    New ROGer Array
    Join Date
    Jul 2020
    Reputation
    10
    Posts
    2

    Linux installed on Asus TUF FX705-DR7N8, issues getting the HDMI port to work

    I have a TUF FX705-DR7N8 with Debian Sid and Windows 10 in dual boot. Works great, aside from not being able to use the Debian partition while connected to my TV. As your typical Linux loving neckbeard, I hate using my Windows partition and it kills me that I must have Windows if I want to use this computer for gaming. Since I've not been able to get the hdmi port to work in linux, I've not done near the amount of development I would like to have with this laptop. I've tried using Windows for development, but that has thus far always ended with me further hating windows and cursing Bill Gates both aloud and in my head. After speaking with Asus technical support, they told me about it using optimus in windows, which made sense with my original suspicion of the GTX 1650 not being allowed access to the HDMI port, since it is thusly configured to use the integrated GPU by default, using the external GPU only when needed. On linux, I have it configured to use the Nvidia GPU by default, ignoring the Ryzen Integrated GPU. While it is using the built in display, it works fine, however it is not able to use the HDMI port.

    I am curious if anyone else has input as to the source of my issue, I would like to hear it.
    Have a day. It's your choice if it's good or bad.

    EDIT:
    While preforming a clean install of the Nvidia drivers on windows, the HDMI port stopped working temporarily after the previous driver was uninstalled, and the new driver was being installed. This tells me that the source of my issue is likely the Nouveau Drivers being used on linux. I have issues getting Nvidia's proprietary drivers to install on linux, so if anyone has any information, I'm all ears.

    EDIT:
    This was not the source of my issue. After upgrading to the proprietary drivers, the HDMI port does not work still.
    Last edited by Lousifr; 08-11-2020 at 01:52 PM.

  2. #2
    New ROGer Array
    Join Date
    Jul 2020
    Reputation
    10
    Posts
    2

    The connection status is being registered in the Nvidia settings panel, but not when I go to display configuration.
    Disconnected:

    Connected:

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •