Results 1 to 3 of 3
  1. #1
    ROG Member Array
    Join Date
    Dec 2011
    Reputation
    10
    Posts
    8

    Prime X570-Pro No sound from optical out and no option for 5.1 sound only stereo?

    I recently built a new system using an Asus Prime X570-Pro motherboard and Ryzen 3950X, I also have a set of Logitech Z906 5.1 surround sound speakers; I have my system attached to the speakers by optical SPDIF cable and nothing I've tried has been able to get the sound to work on any level and in the sound control panel applet on the Playback tab "Realtek Digital Output" is set as the default device and the meter to the right does show output when I play something but nothing comes out of the speakers. These speakers have a series of 5 inputs, 1 being the usual 3 mini stereo and 2 & 3 being optical and I've tried both and I can't get any output on the speakers no matter which of the two optical inputs I'm using. Also in the sound applet under Advanced there is no option for 5.1 sound only 2.1, anyone have an idea why this is? Also I have the latest Reaktek audio drivers installed, version 6.0.8971.1 dated 07/23/2020 from the Asus website; anyone have any idea's?

  2. #2
    ROG Member Array
    Join Date
    Dec 2011
    Reputation
    10
    Posts
    8

    I found the reason for the SPDIF not working, unlike the computer end the speaker end takes more than the usual amount of force to get the optical cable to "click" into the socket but still I can't get the control panel to recognize that there are 5.1 speakers attached?

  3. #3
    ROG Member Array
    Join Date
    Dec 2011
    Reputation
    10
    Posts
    8

    These Logitech X906 speakers have two SPDIF ports and I now also have my other computer hooked up by optical; my older computer has an Asus X99-A II motherboard which has a Realtek ALC1150 8 Channel audio chip and in the option for the sound it does show the option for 5.1 speakers while this latest Asus Prime X570-Pro which has a Realtek S120A 8 channel audio chip with the latest Asus drives does not allow me to choose 5.1 speakers. What exactly is the problem here that I'm not able to select 5.1 speakers?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •