Results 1 to 4 of 4
  1. #1
    New ROGer Array
    Join Date
    Jul 2019
    Reputation
    10
    Posts
    2

    RMA Damaged my device instead of repairing it

    Hello.

    I have a GL704GV notebook I bought from US 1 year ago.
    (Serial number K3NRCV00U978117)

    For the first 6 months I had no major problems. Performance and stability was solid and I was happy with my purchase. However in February, my battery started discharging when my device was off. I was not going to send my device for a repair if it was battery alone in the middle of this pandemic, but I experienced peculiar keyboard malfunctions starting in June. Replacing the battery is a 10 minute job that I could do myself, but accessing the keyboard needs complete disassembly and frankly I did not want to bear the risk and cost of doing it manually.

    After I confirmed my issues were hardware related, I made an RMA request since my international warranty still had a month left.

    My RMA(TRB8L70930) was accepted in 07.07 and my shipment arrived in technical service in Istanbul, Turkey 4 days later. Fast forwarding 1 month, I got it back in 05.08. But this is where my problems started because;

    1- Power cable was not sent
    2- Keyboard was not fixed
    3- And last but not least, they had broken the bottom panel right next to the screw hole in the back corner so i guess they forgot to take out the screw before trying to open it...

    I immediately contacted the customer service and was told tech service would ship the power cord asap. And that I should mail asus support via website about my problems. I was not contacted by Asus for 5 days, customer service isnt answering my calls either.
    My service request number is E2008018631

    I have no idea what to do at this point, my warranty is over and I have 2 weeks left of my vacation.

    I would appreciate any help regarding this entire mess, thank you.

  2. #2
    Moderator Array
    Join Date
    Feb 2019
    Reputation
    13
    Posts
    430

    Hello Madreno,
    I'm really sorry about this.
    May I know more about the original keyboard issue? what happened?
    Also, please kindly share a picture of the panel issue as well.
    I have reported this case to related department to handle it as soon as possible.
    Thank you very much.

  3. #3
    New ROGer Array
    Join Date
    Jul 2019
    Reputation
    10
    Posts
    2

    My left CTRL key works when you press it together with any other key, however keystrokes are not recognized when you press it alone. When it starts happening, %90 of the time single strokes of my left CTRL doesnt work at all. So key combinations such as CTRL + C, V, P etc all work. But in games with CTRL as a keybind, it simply doesnt work most of the time. So Witcher, MHW, DMC5 and such games that I have 600+ hrs is affected a lot by this. I wouldnt care if it was right CTRL tbh.

    I went through keyboard throubleshooting, EoA options in windows, reinsalling keyboard drivers, using safe mode, rolling back Windows updates and finally doing a fresh Win10 installation to diagnose the issue. I am positive its a hardware problem. After RMA it is still present with their factory default installation as well.

    I will send you a PM with some pictures&recordings in an hour if thats alright.
    Last edited by Madreno; 08-11-2020 at 10:29 AM.

  4. #4
    Moderator Array
    Join Date
    Feb 2019
    Reputation
    13
    Posts
    430

    Hello Madreno,
    Thank you so much for the description.
    I will consult more and reply together in PM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •