Page 2 of 2 FirstFirst 1 2
Results 11 to 15 of 15
  1. #11
    ROG Member Array
    Join Date
    Jul 2019
    Reputation
    10
    Posts
    19

    Quote Originally Posted by sevamaxuz View Post
    You can disable System Firmware in Device management concole (devmgmt.msc) and after that downgrade to 307 bios.
    Thank you very much, there is the same problem on my gl504gm biso 312, and i return to 311 by this way.

  2. #12
    ROG Member Array
    Join Date
    Dec 2019
    Reputation
    20
    Posts
    5

    Quote Originally Posted by 棽木 View Post
    Thank you very much, there is the same problem on my gl504gm biso 312, and i return to 311 by this way.
    You are welcome

  3. #13
    ROG Member Array
    Join Date
    Sep 2020
    Reputation
    10
    Posts
    8

    Hi There.

    I have done a bit of reading around & find it hard to get some answers.

    Quick questions.

    Bios:

    I am running 307 which still allows for Undervolting.

    Any luck undervolting with bios version 308?
    Where do I find the change log notes for the bios update?
    Improve System Stability does not really say much.

    Undervolt with Armory Crate:

    Do you use Turbo Mode when undervolting the CPU/GPU or Windows mode?

    What does turbo mode really affect other than the slight gpu OC and faster fans does it increase any voltages on the notebook?

    Hoping to get a little assistance to understand here.

    Thanks in advance.
    Last edited by SciGhost; 10-20-2020 at 07:13 PM.

  4. #14
    ROG Member Array
    Join Date
    Sep 2020
    Reputation
    10
    Posts
    8

    How did you downgrade the bios on this notebook?
    If I try placing the bios file on the flash disk formatted fat32 it indicates it is invalid.
    (yes it is exacted)
    Edit - figured it out, had to extract with folder in tact. Sorted now. Disabled system firmware on device manager so lets see.
    Last edited by SciGhost; 10-20-2020 at 07:42 PM.

  5. #15
    ROG Member Array
    Join Date
    Feb 2019
    Reputation
    10
    Posts
    12

    Quote Originally Posted by sevamaxuz View Post
    You don’t need to uninstall it, what you need is to open the file “devmgmt.msc”, find “System Firmware” device in devises tree and disable it (see attachment). After that you will be able to downgrade your bios to 307 and it will not be updated automatically.
    You can simply roll back to the previous version in the properties. It is not necessary to disable it.

Page 2 of 2 FirstFirst 1 2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •