Page 1 of 2 1 2 LastLast
Results 1 to 10 of 16
  1. #1
    New ROGer Array
    Join Date
    Aug 2020
    Reputation
    10
    Posts
    16

    "ERP Ready" setting missing from ROG Strix X570 E-Gaming BIOS version 2602?

    Let me start off by saying that this BIOS version (2602) has seemingly disappeared from the Asus website today! (8/12/2020). It was there yesterday, and I still have it downloaded on my computer. Right now, the latest listed version for X570 E-gaming is 2408. Maybe something is wrong...

    Anyway, I was on BIOS version 1201 and I decide to update to 2602 to try and fix an issue with Sleep on Windows. Everything went fine, except now there is no "ERP Ready" setting in BIOS! Does anyone know why it was removed?

    This setting was useful for making all LEDs turn off after shutdown. Now my motherboard lights turn red and remain ON after shutdown. Also, the two really bright power LEDs on my ROG Strix RTX 2070 Super remain ON after shutdown. Also, if I power off then power on my PSU, without booting anything, all of my USB ports decide to power on.

    Please note that all of my regular RGB turns off. I have Aura BIOS settings and Aura Sync settings configured properly. I have power delivery in S5 state set to disabled. Does anyone have another setting for me to try?

    I've been attempting to downgrade my BIOS to old versions (2408, 1405, 1404, 1201) through EzFlash, but it is not working. "Selected file is not a proper BIOS!" There's a note on BIOS 1404 that says "You will not be able to downgrade your BIOS after updating to this BIOS version". I figured I would at least be able to downgrade to versions after 1404 then?

    I've been talking to Asus support, but I haven't made any progress in fixing the LED settings or getting my BIOS to downgrade. They also haven't acknowledged the lack of the ERP Ready setting or why it was removed.

    Any help is greatly appreciated! I searched the forums for similar posts and didn't really find anything, but sorry if this is somehow a duplicate.

    Hardware: ROG Strix X570 E-gaming, ROG Strix RTX 2070 Super, AMD Ryzen 7 3700x, Corsair Vengeance LPX 2x8GB DDR4 3600MHz, Corsair RMx 750 W 80+ Gold
    Software: BIOS version 2602, latest Windows Updates, latest AMD x570 Chipset drivers, latest NVIDIA drivers

    TLDR:
    1. ERP Ready setting missing from BIOS 2606 for X570 E-gaming
    2. Certain LEDs on Mobo and GPU will not turn off after shutdown
    3 Unable to downgrade BIOS through any method

  2. #2
    New ROGer Array ShyGuy2 PC Specs
    ShyGuy2 PC Specs
    MotherboardAsus x570-e Gaming
    ProcessorRyzen 3700X
    Memory (part number)F4-3600C16D-32GVKC
    Graphics Card #1EVGA 2070 Super
    MonitorDell U2718Q
    Storage #1WD 1TB BLACK SN750 NVME SSD
    Storage #2WD 1TB BLACK SN750 NVME SSD
    CPU CoolerNoctua NH-U12S
    CasePhanteks p600s
    Power SupplyCORSAIR RM750x
    Keyboard Logitech G613
    Mouse Logitech G703
    Mouse Pad Logitech Powerplay
    OS Windows 10 PRO Version 2004 : Build 19041.508

    Join Date
    Aug 2020
    Reputation
    10
    Posts
    9

    I am stuck on the same BIOS version and the ERP setting is there. Clear your CMOS.

    Also, switching to "AURA OFF" helped with the MOBO LED's not turning off after shutdown.

  3. #3
    New ROGer Array
    Join Date
    Jul 2020
    Reputation
    11
    Posts
    21

    Where did you get BIOS 2602? It's not in the list here: https://www.asus.com/us/Motherboards...HelpDesk_BIOS/

    2407 seems to be latest...

  4. #4
    New ROGer Array
    Join Date
    Aug 2020
    Reputation
    10
    Posts
    1

    I was in the same situation. Flashed to 2606 and was unable to downgrade to 2408. Then I tried to flash back via the back panel USB port with PC shut down and that worked. Im now on 2408. BIOS file must be renamed with the included tool. Just plug the USB Stick in an press the button next to the USB flashbak port for a few seconds until it starts flashing. When the flashing stops you can power on your PC. You will loose all your BIOS profiles when using that mehtod, so safe your settings to an exteral file first.

  5. #5
    New ROGer Array
    Join Date
    Aug 2020
    Reputation
    10
    Posts
    16

    Quote Originally Posted by Dan69 View Post
    Where did you get BIOS 2602? It's not in the list here: https://www.asus.com/us/Motherboards...HelpDesk_BIOS/

    2407 seems to be latest...
    That's where I got it. Read the beginning of my first post.
    I found some helpful information and other people talking about it here:
    https://rog.asus.com/forum/showthrea...-update/page28


    I was finally able to downgrade my BIOS by clearing CMOS right before attempting to use Flashback. Other flashback attempts did not work. I downgraded to version 1405, which I think is the latest version that still has ERP Ready. Everything shuts off again!

    "Aura Off" in "working state" DOES turn off the motherboard lights after shutdown. However, it also disables my RGB, and the GPU power LEDs remain on after shutdown. ERP Ready in S5 is the only thing that works for me.

    Does anyone know why they removed ERP Ready from newer BIOS versions? Asus support dodged the question every time while I was trying to get help on this issue. I hope it comes back in a future BIOS update.

  6. #6
    New ROGer Array
    Join Date
    Aug 2020
    Reputation
    10
    Posts
    8

    Quote Originally Posted by Gigaflux View Post
    That's where I got it. Read the beginning of my first post.

    Does anyone know why they removed ERP Ready from newer BIOS versions? Asus support dodged the question every time while I was trying to get help on this issue. I hope it comes back in a future BIOS update.
    The motherboard had problems with detecting wifi and bluetooth.

    Also, a new bios is out. (2606)

  7. #7
    New ROGer Array ShyGuy2 PC Specs
    ShyGuy2 PC Specs
    MotherboardAsus x570-e Gaming
    ProcessorRyzen 3700X
    Memory (part number)F4-3600C16D-32GVKC
    Graphics Card #1EVGA 2070 Super
    MonitorDell U2718Q
    Storage #1WD 1TB BLACK SN750 NVME SSD
    Storage #2WD 1TB BLACK SN750 NVME SSD
    CPU CoolerNoctua NH-U12S
    CasePhanteks p600s
    Power SupplyCORSAIR RM750x
    Keyboard Logitech G613
    Mouse Logitech G703
    Mouse Pad Logitech Powerplay
    OS Windows 10 PRO Version 2004 : Build 19041.508

    Join Date
    Aug 2020
    Reputation
    10
    Posts
    9

    Quote Originally Posted by Dan69 View Post
    Where did you get BIOS 2602? It's not in the list here: https://www.asus.com/us/Motherboards...HelpDesk_BIOS/

    2407 seems to be latest...

    Because they took it down for some reason.

  8. #8
    New ROGer Array
    Join Date
    Aug 2020
    Reputation
    10
    Posts
    16

    Quote Originally Posted by kush_ View Post
    The motherboard had problems with detecting wifi and bluetooth.

    Also, a new bios is out. (2606)
    Okay, thanks. I personally haven't had any wifi/bluetooth problems while using ERP Ready. Does anyone think that they will bring back ERP Ready in a future update?

  9. #9
    New ROGer Array ShyGuy2 PC Specs
    ShyGuy2 PC Specs
    MotherboardAsus x570-e Gaming
    ProcessorRyzen 3700X
    Memory (part number)F4-3600C16D-32GVKC
    Graphics Card #1EVGA 2070 Super
    MonitorDell U2718Q
    Storage #1WD 1TB BLACK SN750 NVME SSD
    Storage #2WD 1TB BLACK SN750 NVME SSD
    CPU CoolerNoctua NH-U12S
    CasePhanteks p600s
    Power SupplyCORSAIR RM750x
    Keyboard Logitech G613
    Mouse Logitech G703
    Mouse Pad Logitech Powerplay
    OS Windows 10 PRO Version 2004 : Build 19041.508

    Join Date
    Aug 2020
    Reputation
    10
    Posts
    9

    Quote Originally Posted by Gigaflux View Post
    Okay, thanks. I personally haven't had any wifi/bluetooth problems while using ERP Ready. Does anyone think that they will bring back ERP Ready in a future update?
    I have BIOS 2606 and ERP is there. Might have to clear your BIOS settings for it to actually work. I recommend doing this after every BIOS update as ASUS seems to have some kind of persistent bug where a BIOS flash messes with some settings unless it's cleared

  10. #10
    New ROGer Array
    Join Date
    Aug 2020
    Reputation
    10
    Posts
    16

    Quote Originally Posted by ShyGuy2 View Post
    I have BIOS 2606 and ERP is there. Might have to clear your BIOS settings for it to actually work. I recommend doing this after every BIOS update as ASUS seems to have some kind of persistent bug where a BIOS flash messes with some settings unless it's cleared
    Today I tried updating to 2802. Everything seems to be fine. However, I cleared CMOS like you suggest, and there is still no ERP Ready setting. Some people seem to have it, and some don't. I'd really like to know why it's not showing up for me lol.

    Click image for larger version. 

Name:	201024135744.jpg 
Views:	0 
Size:	93.9 KB 
ID:	86596

Page 1 of 2 1 2 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •