Results 1 to 4 of 4
  1. #1
    ROG Enthusiast Array
    Join Date
    Jan 2013

    Horribly slow internet on new build Windows 10 Pro

    I need some serious help here!

    I finished a build using the Asus Crosshair VIII Hero motherboard.

    My internet speeds on BOTH ports are only getting to 100Mbps. I have tested the same cable/connection on two other Asus motherboards ALSO running Windows 10 Pro and they are getting 500 Mbps+. My provider speeds are 1 Gig down and 30 Mbps up. My upload speed is fine at 30 Mbps.

    I have removed almost all other software from my computer to include the Asus software for RGB. I have tried everything listed on the internet to include Powershell tweaks, TCP Optimizer & updated drivers from Intel. NOTHING is fixing this and its not an issue with any of my network equipment.

    WTH is going on? Just trying to log into this forum was a nightmare!

    I need help for the love of all things please!!!!


  2. #2
    ROG Guru: Orange Belt Array xeizo PC Specs
    xeizo PC Specs
    Laptop (Model)HP i7-7500U 16GB 256GB NVMe
    MotherboardAsus Crosshair VII Hero
    ProcessorR9 5900X
    Memory (part number)32GB G.Skill Trident Z RGB 3800MHz
    Graphics Card #1EVGA RTX3070 FTW3 ULTRA
    Sound CardMotu M2
    MonitorAOC 1440p 27" S-PLS
    Storage #11TB Samsung 970 Plus NVMe
    Storage #2plenty
    CPU CoolerNoctua NH-D15
    CaseNZXT H700
    Power SupplyCorsair RM850x
    Keyboard Logitech G710+ MX Brown (50$ on sale)
    Mouse Steelseries Sensei RAW
    Headset Sennheiser HD600
    Mouse Pad Steelseries, hard
    Headset/Speakers Swissonic ASM5 active studio monitors (
    OS Windows10 Pro
    Network RouterAsus RT-N66U

    Join Date
    Apr 2016

    I had a similar problem, using Windows own network adapter reset in settings cured it
    R9 5900X - X570 Crosshair VIII Hero/WiFi(bios 3101) - 32GB G.Skill Trident Z RGB@3800 - Noctua NH-D15 - EVGA RTX3070 FTW3 ULTRA - NZXT H700 w. fans - Corsair RM850x - 1TB 970 Evo Plus

  3. #3
    New ROGer Array polyh3dron PC Specs
    polyh3dron PC Specs
    MotherboardAsus ROG Crosshair VIII Dark Hero X570
    ProcessorAMD Ryzen 9 5950X
    Memory (part number)G.Skill Trident Z Neo F4-3600C14Q-64GTZN
    Graphics Card #1Nvidia Geforce RTX 3090 Founder's Edition
    Sound CardAvid Pro Tools MTRX Studio w/ Pro Tools HD Native Card
    MonitorAsus ROG Swift PG27UQ
    Storage #1Sabrent Rocket 4.0 2TB x2 in RAID 0 Config
    Storage #2WD Black 6TB HDD
    CPU CoolerEK Water Blocks Custom Loop
    CaseLian Li O11D XL
    Power SupplySeasonic Prime PX-1000
    Keyboard Das Keyboard 4 Professional
    Mouse Steelseries Sensei
    Headset Sennheiser GSP 600
    Mouse Pad Steelseries
    Headset/Speakers JBL LSR708p
    OS Windows 10 Pro
    Network RouterEero Pro

    Join Date
    Oct 2019

    If you've installed the GameFirst V app that Armoury Crate told you to install, uninstall it NOW.

  4. #4
    New ROGer Array
    Join Date
    Jan 2021

    Same issue

    Did you ever figure out the cause and get it fixed? I am having the same issue. I have tested my connection on multiple computers with the same cables. I've tested directly to the modem. I have ran the windows network reset function. I've tried installing updated or different drivers. I even did a completely new install of Windows and I'm still having the issue. I'm on a 50mb/s connection and that computer gets around 10mb/s with everything else on the network getting 50mb/s and I get massive ping spikes on that system.

    Any help would be greatly appreciated.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts