Results 1 to 10 of 10
  1. #1
    New ROGer Array
    Join Date
    Apr 2020
    Reputation
    10
    Posts
    1

    Asus ROG Zephyrus G14 - Black Screen

    I bought a ROG Zephyrus G14 a little over a week ago. So far, it's been great, except that when doing non-game related items that uses the Nvidia card, my screen randomly goes dark. There's no way to bring it back (that I can find) except to restart the laptop, and lose what I am currently working on.
    I have updated all drivers to the latest ones, and am still having the same issue. There's no rhyme or reason when it occurs - it's just random.
    Has anyone else experienced this, or have any suggestions?

    I have not yet reached out to Asus about this - just wanted to get ideas from the community first.

    If I can't get this resolved quickly, I have to make a decision if I am just going to return the laptop before the return window closes.

    Thanks for any help/input!

  2. #2
    ROG Junior Member Array
    Join Date
    Nov 2015
    Reputation
    10
    Posts
    1

    I have the same issue, but as far as i know, it happens when fps change rapidly, when scrolling on 9gag for example or alt-tabing from Google Chrome to a zoom video conference. It might be an issue with integrated graphics and nvidia optimus or freesync

  3. #3
    Moderator Array
    Join Date
    Feb 2019
    Reputation
    14
    Posts
    714

    Dear both,
    May you check of you have installed below Windows Update KB?
    KB4550945
    KB4549951
    KB4541335
    KB4551762
    KB4540673
    KB4535996
    KB4532695
    KB4532693
    Please kindly remove them, and then stop the Windows update, in case they are installed back.
    And let me know if the black screen issue still happen.
    Thank you.

  4. #4
    New ROGer Array
    Join Date
    May 2020
    Reputation
    10
    Posts
    3

    The reason is just an AMD graphic driver problem, it happens when Chrome uses HW acceleration.

    https://www.reddit.com/r/ZephyrusG14...ix_megathread/

  5. #5
    Moderator Array
    Join Date
    Feb 2019
    Reputation
    14
    Posts
    714

    Dear all,
    The new Windows Update had been released to solve this issue.
    Please check update !
    Thank you,
    Last edited by Blake@ROG; 05-28-2020 at 08:28 AM.

  6. #6
    New ROGer Array milosrq's Avatar
    Join Date
    Jun 2020
    Reputation
    10
    Posts
    1

    All Windows Updates Done - Still Happening

    Hello,

    I have a new G14 - all updates are complete and this is still happening. Especially when using Chrome (my preferred browser since its conception).

    Any advice on how to move forward or if there is another update coming? or?

    PS - I tried to call support. They were USELESS - The individual was unaware of this issue. They wanted me to perform a hard reset on the laptop and to reset the bios again. I also just updated the bios to the most recent last night. I asked specifically if they had updates on this known and documented issue referencing to this post and others online. The rep was seemingly unaware and still wanted to go through the standard troubleshooting steps despite. I thanked them for their time and ended the call. I worked for Dell for years prior to them moving overseas. I understand the troubleshooting guides call center staff have available to them.

    Please help and advise. I really like this laptop. I just need to know what is going on and when there may be another update to fix this issue.

    Thanks much! ~ (\/)ilo

  7. #7
    Moderator Array
    Join Date
    Feb 2019
    Reputation
    14
    Posts
    714

    Hello milosrq,
    If you still have black screen issue, please kindly stop auto Windows update.
    Just like Wertzius said, you may disable the hardware acceleration in Chrome.
    Also, please kindly remove the windows KB listed above,
    double check if you have updated to BIOS 212 and chipset driver V26.20.14048.2
    https://www.asus.com/Laptops/ROG-Zep...Desk_Download/
    Thank you.

  8. #8
    ROG Member Array
    Join Date
    Sep 2014
    Reputation
    10
    Posts
    11

    Quote Originally Posted by bld93 View Post
    I bought a ROG Zephyrus G14 a little over a week ago. So far, it's been great, except that when doing non-game related items that uses the Nvidia card, my screen randomly goes dark. There's no way to bring it back (that I can find) except to restart the laptop, and lose what I am currently working on.
    I have updated all drivers to the latest ones, and am still having the same issue. There's no rhyme or reason when it occurs - it's just random.
    Has anyone else experienced this, or have any suggestions?

    I have not yet reached out to Asus about this - just wanted to get ideas from the community first.

    If I can't get this resolved quickly, I have to make a decision if I am just going to return the laptop before the return window closes.

    Thanks for any help/input!
    Be sure that all your screens are running at correct htz. I am using 60hz for all 3 of mine when running 3 monitors.

  9. #9
    ROG Member Array
    Join Date
    Sep 2014
    Reputation
    10
    Posts
    11

    I also have had concerns about VR software since after all the headset is another monitor so I uninstalled everything VR related and that cleared things up for me.

  10. #10
    ROG Member Array
    Join Date
    Sep 2014
    Reputation
    10
    Posts
    11

    Yes, it's confirmed for me, it was the occlusion software causing my screen blackouts. I also was amazed at all the apps oculus installed on my phone.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •