Results 1 to 3 of 3
  1. #1
    New ROGer Array
    Join Date
    Feb 2019
    Reputation
    10
    Posts
    1

    Disable Windows Auto Updating BIOS for Downgrade (GL703GS)

    I'm trying to downgrade my BIOS to re-enable undervolting as I can't seem to find an option to enable xtu interface. I have the BIOS file from the Asus site but I need to stop Windows auto-updating to the new BIOS again. I don't have the option in my BIOS to disable UEFI Firmware Capsule Updates, so I don't know what to do to stop Windows from auto-updating.

  2. #2
    New ROGer Array
    Join Date
    Mar 2020
    Reputation
    10
    Posts
    2

    Quote Originally Posted by BlueLightMoon View Post
    I'm trying to downgrade my BIOS to re-enable undervolting as I can't seem to find an option to enable xtu interface. I have the BIOS file from the Asus site but I need to stop Windows auto-updating to the new BIOS again. I don't have the option in my BIOS to disable UEFI Firmware Capsule Updates, so I don't know what to do to stop Windows from auto-updating.
    Facing the same problem in G531GW. Tried setting BIOS password but it still forces me to type the password to let the BIOS upgrade to happen, so useless. Instead of undervolting, I have disabled the boost option of the CPU from the advanced power plan settings. That brings down the cpu temps but at the cost of cpu boost clock. Still looking for a solution for BIOS though.

  3. #3
    Super Moderator Array
    Join Date
    Jan 2013
    Reputation
    121
    Posts
    2,250

    Hi,

    Thanks to sevamaxuz for the suggestion and you may want to check the sticky post below under post #8 which includes a screenshot about disabling the system firmware under device manager to see if that helps although not sure if that will cause any other issues.

    https://rog.asus.com/forum/showthrea...ervolt-PROBLEM

    Quote Originally Posted by sevamaxuz View Post
    You don’t need to uninstall it, what you need is to open the file “devmgmt.msc”, find “System Firmware” device in devises tree and disable it (see attachment). After that you will be able to downgrade your bios to 307 and it will not be updated automatically.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •