Results 1 to 3 of 3
  1. #1
    ROG Member Array GettnBetter PC Specs
    GettnBetter PC Specs
    Laptop (Model)Macbook Air M2
    MotherboardZ490-E Gaming
    ProcessorIntel 10900K
    Memory (part number)F4-4000C15Q-32GTZR
    Graphics Card #1EVGA 3090 Kingpin
    MonitorLG C1
    CPU CoolerArctic Freezer II 280
    CaseNZXT 710
    Power SupplyCORSAIR RM1000x

    Join Date
    Aug 2020

    Z490-E Strix issue with Intel i225-V power management

    Every time I put this Z490-E to sleep, the network adapter never reconnects. Driver currently is version

    Connected to a Cisco 9300 multigigabit interface at 2.5gb/sec with portfast enabled or a generic 1GB netgear same issue.

    I have tried unplugging the patch cable and plugging it back in and nothing.

    I tried updating to the latest Intel i225-v drivers, Version no change

    I tried the complete updated armory, no change

    I updating the firmware which is available on the ASUS drivers page to v1.45 and power cycled, no change

    I cleared the entire computer, rebuilt from scratch, no change.

    I can get the network to reattach after sleep is to open device manager, disable the adapter and re-enable it. This is quite annoying

    Or, if I completely disable all power management from the network adapter, that works too but of course, this makes the adapter useless in a wake on lan scenario.

    Has anyone encountered this sleep issue with the i225-v in their device and solved it?

  2. #2
    ROG Member Array rauf PC Specs
    rauf PC Specs
    MotherboardAsus Extreme V Rampage
    Memory (part number)Kingston HyperX Predator 4x8GB 3000MHz DDR4
    Graphics Card #1EVGA Titan X Maxwell
    Graphics Card #2EVGA Titan X Maxwell
    Monitor3x ASUS ROG SWIFT 27" 1440p + Acer Predator X34 34" 21:9
    CPU CoolerEKWB custom loop
    CaseInWin 909
    Power SupplySuper Flower 1600W Titanium
    Keyboard Logitech G105 + Tracer Hunter
    Mouse Razer Taipan + DeathAdder
    Headset Razer Tiamat 7.1 + MadCatz Tritton Warhead 7.1
    Headset/Speakers Audio Technica AT2020
    OS WinX
    Accessory #1 Fanatec Clubsport simracing rig

    Join Date
    Oct 2015

    Had similar issue on Z490 Apex. Try unistall drivers, then reinstal Chipset and all drivers for Network.
    Hope that helps!

  3. #3
    ROG Enthusiast Array BenchAndGames's Avatar
    Join Date
    Mar 2013

    Just a faulty hardware, hope they start to implement the version3 on Z490 boards

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts