Results 1 to 10 of 10
  1. #1
    New ROGer Array
    Join Date
    Apr 2020
    Reputation
    10
    Posts
    7

    G74SX Shutting down on medium load

    Hello all,

    I am facing some trouble with my 8 year old G74SX-3DE, honestly, it has served me so well that I wouldn't even be mad if I can't fix it.
    The laptop works great, I never had any overheating issues as I open it and clean it every 5-6 months and reapply the thermal paste, and have been doing so for the last 4-5 years. but for the last couple of days when I play some games (Mostly medium heavy nothing to fancy) it shuts down randomly. Tested this with benchmark software, and the same happens, so I know its not a software issue (I also did a clean re-install of widows and the same is happening). The temperature never goes above 70 c for the GPU and CPU likewise, with CPU having higher fluctuations as it cools down faster I guess. All in all the temperature is more than fine as far as I can tell, but it can't hold for too long once its above 60 c. I can have it on for the entire day if I am just surfing the web, doing light work, etc...
    Also, doing only a CPU stress test will not shut down the laptop.
    First It used to crash right as the GPU reaches 60 degrees. then i swapped the fans as I suspected something wrong with the sensors (and they look identical). and now it can hold for about an hour before shutting down. benchmark got it to 76 c without shutting it down, but i never left the benchmark running more than 15minutes. I swapped the fans back to see if it will again shut down immediately, but it stil holds on for a longer period, although I had it shut down in 2minutes once.
    what is also strange, is that using HWiNFO64 i was able to see the CPU and GPU fan speed under ASUS NB EC, but as I swapped the fans around (and also after I swapped them back) I can no longer see (Screenshot attached) and the sensor is enabled.
    This randomness is what is confusing me so much, is it the fans? is it the sensor? is it some safety feature that I can turn off? as I always monitor temperatures and I never see it overheat.
    If you guys have any ideas or suggestions, please let me know.

    Thanks in advance!
    Miniatura de Adjuntos Miniatura de Adjuntos HWiNFO64.JPG  


  2. #2
    ROG Guru: Green Belt Array
    Join Date
    Nov 2012
    Reputation
    75
    Posts
    740

    How about a screenshot of your Device Manager?

    What kind of hard drives are you using? Sata SSDs?

    What sort of programs are running in the background? Perhaps a screenshot of the Task Manager would show?

    My wife likes to say the PC is like a aquarium, blame problems on the last fish you added. What changes did you make to the laptop before the problems occurred?
    G752VSK, G75VW-3D, G51J, G1S
    Homebuilt Windows Server

  3. #3
    New ROGer Array
    Join Date
    Apr 2020
    Reputation
    10
    Posts
    7

    Quote Originally Posted by jdfrench3 View Post
    How about a screenshot of your Device Manager?

    What kind of hard drives are you using? Sata SSDs?

    What sort of programs are running in the background? Perhaps a screenshot of the Task Manager would show?

    My wife likes to say the PC is like a aquarium, blame problems on the last fish you added. What changes did you make to the laptop before the problems occurred?
    I havent made any changes lately, only installed 5kVideo app to get some youtube videos. which i deleted.
    I also did a fresh install of win10 and the same is happening.
    drivers haven't changed in years since support for this laptop stopped so no new drivers came out. and I havent had a windows update recently.
    I have an SSD 240GB and HDD 750GB. both show good health and work fine in all tests. memory test is also good.
    Here are the screenshots. Just to add, I haven't noticed anything strange, I dont dabble in shady stuff, piracy, extensions, etc...i like my stuff tidy as it has been serving me more than well that way
    Miniatura de Adjuntos Miniatura de Adjuntos DM.JPG  

    TM.JPG  


  4. #4
    New ROGer Array
    Join Date
    Apr 2020
    Reputation
    10
    Posts
    7

    If someone had experience with HWiNFO64, it baffles me that it was recognizing the GPU and CPU fans as shown in my first screenshot but it isn't any longer. could it be that the sensors/fans are damaged? The fans are working I know for sure, but maybe there is a communication issue between them and the motherboard causing the system to think it is not getting enough cooling....if that works that way....not sure...but I feel the issue there. The problem is, I can't find these fans (unless I order them and that takes ages) so I cant swap them that easily.

    Thanks!

  5. #5
    ROG Guru: Green Belt Array
    Join Date
    Nov 2012
    Reputation
    75
    Posts
    740

    As part of your "Clean Windows 10 Install" what drivers are not being installed automatically by Windows 10?

    Using your Device Manager, go down the devices properties and look at the date of the drivers that are presently being used. I think you will be alarmed as to what Windows is updating without your interaction.

    I work on a neighbor's G74, I recall that there are a number of devices that require a specific driver.

    Run Task Manager while running program that causes the laptop to shutdown. You might see a task that's causing the failure.
    G752VSK, G75VW-3D, G51J, G1S
    Homebuilt Windows Server

  6. #6
    New ROGer Array
    Join Date
    Apr 2020
    Reputation
    10
    Posts
    7

    Quote Originally Posted by jdfrench3 View Post
    As part of your "Clean Windows 10 Install" what drivers are not being installed automatically by Windows 10?

    Using your Device Manager, go down the devices properties and look at the date of the drivers that are presently being used. I think you will be alarmed as to what Windows is updating without your interaction.

    I work on a neighbor's G74, I recall that there are a number of devices that require a specific driver.

    Run Task Manager while running program that causes the laptop to shutdown. You might see a task that's causing the failure.
    The only driver i installed is the nVidia driver and Chipset from the asus official g74sx support website. I checked most drivers and they are all years old. the GPU one is from 2018, some are even from 2006. most are from 2011-2012 when this laptop came out. I don't know even if it is a specific driver, why would it start causing issue right now.

    By the way, I realized that I hadn't enabled the EC in HWiNFO64, so I can see the GPU/CPU fans. Basically, I only couldn't see them when I swapped the fans as part of my testing. but they still behave the same way. I will do another stress test now and see how long it goes. it is hard looking at Task Manager, as it shuts down suddenly and if I am alt+tabbed, the stress lowers so it might not fail at all.

    I did clean installs at least twice in the past couple of years getting the windows ISO directly from microsoft website as I have an original key and generally I avoid any shady stuff and piracy. and I always go through the same steps without any issues. I have very few apps on my laptop as I like it tidy. VLC player, BS player, google chrome, windows basic stuff and a couple of games (Battle.net WOW, Hearthstone, Steam, europa universalis 4, civ 5, DOTA) Microsoft office, and thats pretty much it.
    Miniatura de Adjuntos Miniatura de Adjuntos HWFANS.JPG  


  7. #7
    ROG Guru: Green Belt Array
    Join Date
    Nov 2012
    Reputation
    75
    Posts
    740

    Another issue is your battery and charging brick.

    Have you a functioning battery within your laptop? I bet not. I've been looking for a working battery for my neighbor's G74 for some time. I have ordered three different batteries from three different online sites, only to receive flat dead batteries. Once those batteries go dead, they don't charge.

    Your charging brick most likely needs replacing too.

    Good Luck
    G752VSK, G75VW-3D, G51J, G1S
    Homebuilt Windows Server

  8. #8
    New ROGer Array
    Join Date
    Apr 2020
    Reputation
    10
    Posts
    7

    I actually use it without the battery, for few years now. As it died out and i dont really need it. Inhave purchased 2 spare bricks at one point when my original was broken, which i also fixed, and the laptop behaves the same on all three right now, so its almost impossible that all three broke down at the same time. In any case, i will take it to a srrvice shop today. Its gotta be some communication between the gpu and sensors/fans, something on the motherboard that is just old, hopefully it can be fixed. I will post once i have more info.
    Thanks!

  9. #9
    New ROGer Array
    Join Date
    Apr 2020
    Reputation
    10
    Posts
    7

    So the laptop is being serviced right now, waiting to know soon hopefully what is the issue. I have been told that it seems the damage is either to the GPU or something around it. if it's the GPU itself which likely can't be fixed, they can disable the GTX 560m, since there is an integrated Intel HD 3000. my question is, how does Intel HD 3000 handle WOW at minimum settings?I play a few games, but they are all older and I can assume that they can run since they are not graphic intensive. if I can get at least 20-30 frames it might be a solution I go with for the next couple of months until i get the my new PC, as right now I have to limit the GTX 560m so it doesnt heat beyond 45degrees which works in preventing the shutting down, but I can't get more 15 fps.

    TLDR:
    Is World of Warcraft (BFA, not Shadowlands) playable in any state on the Intel HD 3000 integrated graphic in G74SX?

  10. #10
    New ROGer Array
    Join Date
    Apr 2020
    Reputation
    10
    Posts
    7

    So i got the laptop back, very cheap fix, one of the circuits for power was worn out on the motherboard. so as soon as the GPU starts drawing more power it would shut down. all good now

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •