Results 1 to 5 of 5
  1. #1
    New ROGer Array
    Join Date
    Feb 2019
    Reputation
    10
    Posts
    6

    S17 Blue Screen Of Death

    Sup everyone.

    So I purchased my S17 maybe 2 weeks ago. I've been working crazy OT since the pandemic started, so I have only played on the new laptop 5-6xs for 1-2 hours each time. Never had any issues. Thermals had been perfect, nothing special done to the laptop. I only downloaded 3 games. BF3/4 and WOW. I had the latest BIOS, Windows updates and Nvidia drivers. Again nothing special touched or downloaded. No issues while gaming.

    So,
    I'm on my lunch break, decide to jump on BF and play for a few minutes. PC loads up like it normally does. Load up the game. Start playing and not even 3 minutes in, BAM blue screen. Now it will not load into windows. It does one of the following when you hit the power button.

    1. Keyboard lights up, screen stays black, and thats it.

    2. Keyboars will light up, ROG logo will display, the loading circle will show, then it freezes.

    3. Rarely, it will show the ROG logo, go black, then show again, but say something like asus repair or something. Then load into the troubleshooting screen. Sometimes it will freeze then, sometimes I can get as far as starting a clean install, then it will freeze.

    So, I'm stumped. Any thoughts? RMA and be done? I'm not opening up the laptop. Not taking the chance of them tossing blame on me for opening it up and changing out the SSD or RAM to see if that corrects it.

  2. #2
    New ROGer Array
    Join Date
    Feb 2019
    Reputation
    10
    Posts
    6

    Forgot to mention if it matters. Its the S17 with the 2070 super and Windows pro.

  3. #3
    New ROGer Array
    Join Date
    Jul 2020
    Reputation
    10
    Posts
    22

    I am on my second RMA

  4. #4
    New ROGer Array
    Join Date
    Feb 2019
    Reputation
    10
    Posts
    6

    For this issue?

  5. #5
    Moderator Array
    Join Date
    Feb 2019
    Reputation
    13
    Posts
    475

    Hello Brad,
    May I have the complete model name? GX701XXX?
    and do you have the error message of the blue screen?
    Please also refer to below FAQ as well
    https://www.asus.com/support/FAQ/1042613/
    Thank you.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •