Results 1 to 2 of 2
  1. #1
    New ROGer Array
    Join Date
    Sep 2020
    Reputation
    10
    Posts
    2

    ROG STRIX X570-E/X570-F PCIe lane assignment

    I am considering the STRIX X570-F motherboard for a new Ryzen build.

    I plan to run a single RTX 30x0 GPU, a 10G SFP+ NIC, a single M.2 x4 NVMe drive, and 2x SATA SSDs.

    My understanding of the AMD X570 architecture is that I can run the GPU at x16 using lanes off the CPU, the M.2 at x4 using lanes off the CPU, and then the SATA and PCIe x4 NIC using the X570 PCH.

    The English manual states that PCIeX16_3 slot is shared with lanes on M.2_2, however the Japanese manual states that the PCIEX16_3 slot is shared with lanes for PCIEX1_2

    The English manual also shows configuration options for 1, 2 and 3 GPUs/PCIE cards for the three PCIEX16 slots, with options of x16/NA/NA, x8/x8/NA, and x8/x8/x4. This does show that there are an extra 4 lanes that appear for slot 3, with 16 still remaining available for the first two slots.

    Does anyone have one of these boards where they're running a GPU at x16, and another non-GPU add in card at x4 that can confirm whether this will actually work? While I understand that PCIe 4.0 x8 is the same speed as PCIe 3.0 x16, I'd prefer to have the ability to retain all 16 lanes for the primary GPU slot while still running an add-in card in the x4 slot.

    Thanks in advance for any assistance!

  2. #2
    ROG Member Array New Ninja PC Specs
    New Ninja PC Specs
    MotherboardAsus Rog Strix x570-E Gaming
    ProcessorR9 5900X
    Memory (part number)F4-3600C16D 64GB
    Graphics Card #1EVGA NVIDIA GeForce RTX 3080TI FTW3
    MonitorLG 27GP850-B Ultragear Gaming Monitor 27” QHD
    Storage #1ADATA XPG SX8200 Pro 1TB 3D NAND NVMe Gen3x4 PCIe M.2
    Storage #2Samsung 850 EVO - 1TB - M.2 SATA III Internal SSD
    CPU CoolerCorsair H115i Platinum
    CaseCorsair 600T
    Power SupplyCorsair HX1200
    Keyboard Logitech G910
    Mouse Razer Viper Ultimate
    Headset Astro A50
    OS Windows 10 Pro x64

    Join Date
    Jul 2017
    Reputation
    10
    Posts
    8

    im having a similar issue here. added two m.2 drives and it seems that none of the PCIE are not being detected by a pcie adapter for a 3rd nvme. Any work around for the x570-e?
    See specs...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •