Results 1 to 3 of 3
  1. #1
    New ROGer Array
    Join Date
    Mar 2012
    Reputation
    10
    Posts
    1

    maximus iv gene-z/gen3 watercool advice

    hi guys, a newbie here in relation to watercooling

    help to what the best watercooling system to "fit" in my assembly. and what would be the the best assemble or just by a kit.
    Here is my specs..

    MOBO: Maximus IV GeneZ/Gen3
    Memory: GSkills Sniper 8gb (4x2)
    Processor: Intel iCore 5 2500k 3.3Ghz (unlocked)
    Casing: Thermaltake Level 10GT
    Power Supply: Thermaltake Toughpower XT 775w

    as u may notice there is no display adapter yet on the setup, which brings me to my 2nd question of should i bought 1st a graphic card before i start assembling a watercool loop.

    thanks

  2. #2
    ROG Member Array
    Join Date
    Mar 2012
    Reputation
    10
    Posts
    12

    Hey,

    You looking to have quite system or overclocked system. You could buy a Corsair H100 CPU cooler and that will bolt to top of your case but think you'll have remove existing exahust fan from top of case. You could also buy each individual item depending on what you want to cool. I know the basics of watercooling but never tried to do much watercooling as I studies Electrical and Mechanical engineering at University and never liked cooling systems.

  3. #3
    ROG Member Array
    Join Date
    Jan 2012
    Reputation
    10
    Posts
    10

    H-100 for ease of assembly and quite frankly the kits from EK are really good, plus theyre upgradable which means if you'd like a waterblock for any specific GFX you can upgrade it, whereas the H-100 is effectively locked down.

    So my tip is google for the EK kits and see what you find, otherwise for cpu alone any 1x120 or 2-3x will cool the cpu plenty all the way up to 5ghz+ (if you get a good cpu sample that actually can do 5ghz)

    //best regards, azure
    CPU: Core i7 2600K @ 4.6 (4.6g lvlup)
    MB: Maximus GENE 4/gen3
    MEM: Dominator GT 2133mhz 16gb-kit
    PSU: AX-850
    COOL: H-100 @ (35c-idle/66c-Linxload)
    GFX: 2x7970 @ 1150/1500 (38-40c-idle/77-80c load)
    SSD: 120gb Vertex 3, 60gb intel 320 SRTdrive
    HDD: 1x 2tb barracuda greeny, 1x 500gb momentus xt

    Working as a charm!

    LAP: G73Jw : not working quite as well

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •