Page 1 of 5 1 2 3 ... LastLast
Results 1 to 10 of 42
  1. #1
    New ROGer Array
    Join Date
    Aug 2020
    Reputation
    10
    Posts
    10

    Armoury Crate.User Session Helper.exe cpu usage

    run in backround and with silent mode cpu usage is almost 30% and 3.7ghz...
    help please...

  2. #2
    New ROGer Array
    Join Date
    Apr 2020
    Reputation
    10
    Posts
    11

    Talking

    Same here, I am using a G531GW and the Armoury Crate User Session Helper.exe has increase in cpu usage, mine is about 15% on idle. This causes my cpu fans to be louder than usual.

    I think it has to do with the recent Armoury Crate update.

    Now just hoping it gets fixed soon.
    Last edited by JonTeoh; 09-18-2020 at 03:54 PM.

  3. #3
    New ROGer Array vashish27 PC Specs
    vashish27 PC Specs
    Laptop (Model)ROG Strix SCAR II
    MotherboardGL504GW
    ProcessorIntel i7 8750H
    Graphics Card #1nvidia GeForce RTX 2070 mobile

    Join Date
    Aug 2019
    Reputation
    18
    Posts
    52

    Hey there,

    I have seen in another thread, other users having same problem including myself. Already posted about this but posting here again for users who have not checked the other thread and maybe someone can come up with a temporary solution.
    Concur with Jon above that this started after yesterday's update of AC service and AC software.
    Click image for larger version. 

Name:	AC.jpg 
Views:	0 
Size:	82.8 KB 
ID:	86314

  4. #4
    ROG Member Array
    Join Date
    Jun 2012
    Reputation
    11
    Posts
    16

    I have a G732LWS and I am also currently suffering from the same issue. Constant CPU usage from the User Session Helper Service
    Asus G75VW
    Geforce GTX 660m

  5. #5
    New ROGer Array
    Join Date
    Jun 2020
    Reputation
    10
    Posts
    4

    Quote Originally Posted by souliar7 View Post
    run in backround and with silent mode cpu usage is almost 30% and 3.7ghz...
    help please...
    I have same problem with my G531GU.

  6. #6
    New ROGer Array
    Join Date
    May 2020
    Reputation
    10
    Posts
    3

    Same problem here with a GX502GW.

    Armoury Crate.User Session Helper.exe is taking a whole CPU core, probably stuck in a weird loop. I found a workaround:

    - Open the Armoury Crate app.
    - Close it.
    - Kill Armoury Crate.User Session Helper.exe using the Task Manager.

    Armoury Crate.User Session Helper.exe will restart and stay idle as expected.

    I love my laptop but damned this Armoury Crate stuff is a huge mess...

  7. #7
    New ROGer Array
    Join Date
    Aug 2020
    Reputation
    11
    Posts
    18

    Quote Originally Posted by smod42 View Post
    Same problem here with a GX502GW.

    Armoury Crate.User Session Helper.exe is taking a whole CPU core, probably stuck in a weird loop. I found a workaround:

    - Open the Armoury Crate app.
    - Close it.
    - Kill Armoury Crate.User Session Helper.exe using the Task Manager.

    Armoury Crate.User Session Helper.exe will restart and stay idle as expected.

    I love my laptop but damned this Armoury Crate stuff is a huge mess...
    Thanks!

  8. #8
    New ROGer Array vashish27 PC Specs
    vashish27 PC Specs
    Laptop (Model)ROG Strix SCAR II
    MotherboardGL504GW
    ProcessorIntel i7 8750H
    Graphics Card #1nvidia GeForce RTX 2070 mobile

    Join Date
    Aug 2019
    Reputation
    18
    Posts
    52

    Found an easier fix, just disable background functionality of Armoury Crate in Windows Settings >> Background apps.
    I wanted to check before posting, there in no affect on the Armoury Crate functionality. Keyboard Lighting and fan modes are working normally as before.
    Good thing, no need to do it every restart.
    Click image for larger version. 

Name:	AC solution.jpg 
Views:	0 
Size:	167.9 KB 
ID:	86327

  9. #9
    New ROGer Array
    Join Date
    Jul 2020
    Reputation
    10
    Posts
    4

    The same problem here with my G731GW laptop.

  10. #10
    New ROGer Array
    Join Date
    May 2020
    Reputation
    10
    Posts
    3

    Quote Originally Posted by vashish27 View Post
    Found an easier fix, just disable background functionality of Armoury Crate in Windows Settings >> Background apps.
    Just tried this and I don't see any impact either. Even better, thanks!

Page 1 of 5 1 2 3 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •