Results 1 to 1 of 1
  1. #1
    ROG Junior Member Array
    Join Date
    Jun 2018

    Asos ROG G703 cant start with anything is USB port

    Hi guys.

    After the recent new version of windows update together withj some update for the .net framework my Asos rog G703 wotn start unless I unplug the USB devices.

    Its no Biggie, Just very annoying and clearly something is not right here.


    When trying to start the computer the ROG logo shows, and then the loading circles start rotating around. It remains there indefinently ( ör at least for more than an hour). I have tried all the startup repair options there is.

    I got by it by uninstalling the feature updates, but then when it would not start again and I downgraded to previous version of windows. Then it worked, however windows wants to update since the old version is at the end of life.

    I found out that after the updates when the computer do not to start, if I unplug my mouse and my cubase hardware key, the computer starts, and I can replug them and everything works.

    Just my report, and maybe someone knows a fix?

    Thanks /Jimmi
    Last edited by mrjimp; 09-20-2020 at 01:57 AM. Reason: More info, and miss spellings

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts