Results 1 to 2 of 2
  1. #1
    New ROGer Array
    Join Date
    Jun 2020
    Reputation
    10
    Posts
    2

    Question x470 Strix - Lossy optical & network ports

    Hello folks,

    i got the ASUS ROG Strix X470-F Gaming AM4 AMD Mainboard back in 10/2018. It's running fine so far, no complains on this side. BUT it appears that the optical and network ports getting more and more lossy over time. It's anyoing because just a little contact with the network or optical cable, it falls out of the port or the connections get interrupted, which lead to disconnects or no sound.

    I already called the ASUS Support back a while but the service person wasn't really understanding / helpful what we said due language barrieres.

    The mainboard is still in garantuee life-span, but i need the pc for work and stuff so i didn`t sent it as rma yet.
    Firstly i would like to know if ASUS will do any repairs or just sent a new board which will result in doing a complete system installation and also requires new windows 10 key if i am not wrong.

    Any experiences with this so far? What should i do?

    Thanks you for any response,
    Last edited by dRaMaTiX; 09-28-2020 at 04:53 PM. Reason: Better title

  2. #2
    New ROGer Array
    Join Date
    Jun 2020
    Reputation
    10
    Posts
    2

    Please help

    Nobody here to help? Maybe @ASUS-Support or @mod could take some minutes to reply?

    Question is simple: Will ASUS repair this issue if i send in the mainboard as rma case or replace it and how long would it take?

    Much appreciated,

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •