Results 1 to 3 of 3
  1. #1
    New ROGer Array
    Join Date
    Sep 2020

    After BIOS update, laptop is completely dead.

    Hi all.

    So this is what hapenned.

    I have been having problems with bluetooth on my Strix GL702 VT laptop. It would be working fine , then at random would stop, and there would be no way to turn it back on as the option had dissaoeared from the settings, as if the laptop did not have bluetooth cacability. After some days or weeks, usually after a Windows 10 update, the option would reappear, only to dissapear again at random.

    Whilst looking at Windows update, I saw some optional updates that were available. One of them was a firmware update to the bios.

    So I thought, "OK let's give this a go, it can't hurt"

    I was wrong. After installing the update, the laptop rebooted and the bios update screen appeared, where I saw the flash erased, the new bios installed, and then verified. It all looked like it went OK with no error messages, then it said rebooting...and that's the last time the laptop has worked.

    Now, when I power on, I just get the splash screen "Republic Of Gamers", and that's it. There's no disk activity light, and F2 does not go into the bios.

    After a bit of Googling, I tried opening the laptop up and disconnecting the CMOS battery for an hour, but this has made no difference, it's still dead as a doornail.

    So my question is, can it be fixed, or do I now have to go and buy another laptop?


  2. #2
    New ROGer Array
    Join Date
    Nov 2018

    bios 310 is bugged. you can fix things by downgrading to 306.


  3. #3
    Moderator Array
    Join Date
    Feb 2019

    Hello tigerfox57,
    Really sorry for what had happened.
    Please kindly send your device to our service center.
    Sorry for the inconvenience caused.
    Thank you.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts