Results 1 to 5 of 5
  1. #1
    ROG Junior Member Array
    Join Date
    Nov 2017

    Bios Error Code B2 Load VGA Bios on Rampage VI Omega

    Hello Fellow ROGers!

    I've been having an issue with my Omega mobo and an EVGA 2080 Ti FTW3 ULTRA card. I constantly get a bios error code B2 Load VGA Bios error message. I'll shut down PC and restart. Most of the times, this will work and I'll be able to get into Windows. Has anyone else experienced this? I also wrote to EVGA about this issue, and am trying to figure out if it's the motherboard or the video card.

    Problems also have cropped up when PC is awakened from "sleep" mode, where there will be no video signal being sent out to monitor (requiring me to shut off power to PC.) Yesterday, when actually working on PC, ripping CDs, and suddenly lost video, PC was still going, though because CD completed RIP, and one fan, closest to video ports was spinning at full speed. Again had to force power off on PC and reboot to get video back.

    I've been working around the issue but now it's driving me a bit crazy. Seems to be happening more frequently since updating bios to latest released version, 0802.

    Thank you!

    Miniatura de Adjuntos Miniatura de Adjuntos IMG_2922.jpg  

  2. #2
    ROG Guru: Black Belt Array Hopper64 PC Specs
    Hopper64 PC Specs
    MotherboardAsus R6EE Bios 0070
    Processori9 10900X @ 5.0 1.37V VCore
    Memory (part number)GSkill F4-4000C18Q2-64GTZR
    Graphics Card #1EVGA 3090 FTW Ultra/EKWB Quantum Vector Nickel/Plexi
    Sound CardCreative SB AE7
    MonitorAsus ROG PG349Q
    Storage #1Intel 905p M.2 360G
    CPU CoolerEKWB Magnitude RGB and Quantum Kinetic D5
    CasePhanteks Enthoo Elite
    Power SupplyCorsair AX1600i
    Keyboard Asus Strix Flare
    Mouse Asus ROG Gladius II Origin
    OS Windows 10 64
    Hopper64's Avatar
    Join Date
    Nov 2012

    I’ve seen this occasionally too. Are you over clocking anything? List all your hardware including the memory kit. Remove the video card a blow out the pcie slot. Might be dusty.

  3. #3
    ROG Member Array
    Join Date
    Dec 2018


    Just quick question whats your EVGA card model? FTW3? If yes read this below.

    I used to have same problem. Sadly you will need to change your motherboard because there is no fix to this.

    Running SLI or single 2080TI FTW3 will give that error on Asus motherboards. Asus is silent for almost a year on this ( I reported this problem to their support with 2080ti release).

    You can try to contact Asus and see if they have any new solution.

    ASUS Rampage VI EXTREME this was my motherboard back then. When i updated last bios Version 1704 i was not able to load my EVGA FTW3 cards anymore. I contacted to provide RMA and test my new 2080ti ftw3 cards. They came to conclusion that FTW3 cards ( 20 series) are not supported on ASUS x299 motherboards. They tried new ASUS Rampage VI EXTREME and new model OMEGA (also same error LOAD VGA Bios).

    You either RMA motherboard and ask for different model (i did that with shop they returned my money) or sell your EVGA card and buy Asus card so it will 100% work.

  4. #4
    ROG Guru: White Belt Array
    Join Date
    Dec 2011

    I'm running an EVGA GeForce RTX 2080 Ti FTW3 ULTRA GAMING (single card) on an R6E. I've had that issue since day one (even on the test bench with no OC just to make sure everything worked prior to case installation). It appears to be completely random. Sometimes multiple restarts don't work and I have to drain power from the board by unplugging the PSU from the outlet. I've always managed to get past the error though. I'm running BIOS 1503 with an OC on a 7940X. It's a pain in the ass to deal with but it doesn't happen too often so I just deal with it.

    There's no way I'm going replace my board just for this and I also don't buy the fact that these cards are not supported on Asus X299 motherboards. Besides this minor annoyance the card has been running flawlessly so far.
    Last edited by Homewrecker; 11-10-2019 at 01:48 AM.

  5. #5
    New ROGer Array
    Join Date
    Aug 2020

    Suppose this is a bit of a long shot seen as this thread I so old , but worth a try
    *I have the same problem just start happening everything was fine then after armoury crate did some updates And now seing this code on start up now , did anyone find a work around for this*

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts