Page 3 of 3 FirstFirst 1 2 3
Results 21 to 22 of 22

Thread: Cracking sounds

  1. #21
    ROG Member Array
    Join Date
    May 2018
    Reputation
    10
    Posts
    14

    Quote Originally Posted by MoKiChU View Post
    Hi,

    Hi,

    If that was not enough to fix your issue, try by disabling PCI Express Link State Power Management in your power plan to avoid L0s/L1 state of PCI Express power management mechanism (Windows Control Panel > Power Options > Change plan settings of your current power plan > Change advanced power settings > PCI Express > Link State Power Management : Disabled) or by switching directly to the High performance power plan (Windows Control Panel > Power Options > High performance).
    Mokichu this fix helped a lot with the cracking sounds but again i have some minors cracking every 2-3minutes in gaming or movies..

    Don't know what's causing this.I tried speakers with optical,3.5 jack,usb.Also i tried to disable sound card from bios and my usb headphones had cracking again.

    I was thinking that with a new pci sound card this problem will be solved but now i am thinking that the problem isnt the onboard soundcard.

    Any suggestion to fix 100% the problem??

    Also add this fix on your drivers thread.It really helps a lot with cracking but not 100%.

    Thanks!!
    Last edited by AndrewkROG; 10-21-2020 at 12:46 PM.

  2. #22
    New ROGer Array
    Join Date
    Nov 2019
    Reputation
    10
    Posts
    55

    Quote Originally Posted by metalspider View Post
    i see the z390-i also has the intel i219-v lan just like on my xi hero.that lan card can cause lots of dpc latency spikes due to the interrupt moderation in the advanced driver settings.
    you can try a newer driver or also check in latencymon to see if you have spikes because of tcpip.sys
    Interesting, this mobo is phenomenal for dpc latency z390-i gaming, 100 max us. Nic has like couple us, or couple tenths. Interesting u say, this nic suck, cause intel nic are the best! Also i have it tweaked by speedguide, but pretty sure, dpc lat. was low even before!

    Quote Originally Posted by MoKiChU View Post
    Hi,

    You have an ASUS ROG SS3 motherboard, so :

    You need Realtek Audio Drivers (UAD - ASUS ROG SS3 MB) from the first post of this thread.

    Follow scrupulously your CLEANUP process then your INSTALL process, for the next drivers packages that I would release, you will can directly follow your UPDATE process.

    Once it's done, regarding your popping issue, follow these 2 TIPS (also visible at the bottom of the first post) :

    1) Disable hibernation :

    - Right-click Windows Start button then click Search.
    - Search for cmd. In the search results list, right-click Command Prompt and then click Run as administrator.
    - If/When you are prompted by User Account Control, click Continue.
    - At the command prompt, type powercfg.exe /hibernate off and then press Enter then close the Command Prompt

    2) Enable MSI (Message Signaled-based Interrupts) mode on all your supported devices (see the column "supported modes") with MSI Mode Utility (Right click on "MSI_util_v3.exe" > Run as administrator), then Apply, then close MSI Mode Utility & restart your PC.
    I tried that already. It seems it was windows update, since i updated to 2004 no cracking, except when i alt+tab pc game , or sometimes on stream. But from time to time, that may be normal. Althought i didn't have this on my old pc. But if it doesn't happen when playing games, rarely on a split second when watching tv shows even in linux, but if this is so rare, i don't really care, or if that happens once in a while on stream. So far 2 days it is fine! 3rd day completely fine in games.

    Btw pci-e link power saving in power setting shouldn't do anything, this is controlled by nvidia driver. Nevertheless i have it off to be sure. All other tweaks u said, i was already using. Realtek drivers should put itself to msi automatically. Not always perhaphs? Not sure now.

    Quote Originally Posted by AndrewkROG View Post
    Mokichu this fix helped a lot with the cracking sounds but again i have some minors cracking every 2-3minutes in gaming or movies..

    Don't know what's causing this.I tried speakers with optical,3.5 jack,usb.Also i tried to disable sound card from bios and my usb headphones had cracking again.

    I was thinking that with a new pci sound card this problem will be solved but now i am thinking that the problem isnt the onboard soundcard.

    Any suggestion to fix 100% the problem??

    Also add this fix on your drivers thread.It really helps a lot with cracking but not 100%.

    Thanks!!
    Sorry so chaotic, i am throwing ideas at you, i tried from most important but it got mixed. Anyway, these are all important informations, google it, if not sure, or ask.

    You should try dual boot, if that happens there too? Or linux live usb and watch tv shows, if it happens there. Easier than that, you can try clean boot! Go win+r msconfig, services. Click hide microsoft services and untick everything, see if it happens! It was windows update in my case, i updated to 2004 and it is fine now 2 days. Also make sure all your devices are set to msi/msix mode, if they support it. Find msi_util 2 on 3d guru. CAREFUL IF YOU SET DEVICE TO MSI , WHICH IS NOT SUPPORTED, WINDOWS won't boot!!! So make like restore point (not sure if that would work), or system backup! Nvidia hd audio won't work in msi mode, you need to take hardware ID from msi_util 2 and find it in device manager to know which is it. And google your devices, if they support msi mode, oh msi_util2 should already tell you, if they support msi, but i wouldn't rely on that.

    In any case, if it will be fine in dual boot, you can try to update to 2004, it also fixes windows. Or you can run sfc /scannow and dism. Or use restore point, or if you have backup. Also you can do repair upgrade with installation medium and you can keep your files, don't even have to reinstall! Messes up a lot of settings tho!

    You can try ddu to uninstall nvidia and sound drivers! Read manual carefully!!!

    Set in control panel sound, your speakers , or what you are using, will have green check mark and you see it, when playing sound. Set it to 44100hz 16bit, disable all sound enhacements. Disable everything under exclusive mode, disable signal enhacements. Spatial sound, or surround. Than go back, select your sound device and click configure, select your number of channels, make sure front left and right box is checked , than next or ok. Humans can't hear more than 44100 and more than 16 bit is also useless for consumers. Also higher setting will cause incredible input lag!

    Also someone from asus said on these forums, that it can be , because nvidia gpu takes interrupt priority , before realtek sound card, you can try in msi_util2 increase sound card priority, if you have high dpc latency in latency mon , under your sound driver. I have currently set everything to undefined, except nvme and sata controller to high.

    You can try bios update - read instructions carefully, even new motherboards should save your from bricking bios, update all other drivers.

    You can try disable nvidia adapter in device manager, it can be caused by nvidia drivers i read and see if it continues to happen. GPU should still work, it will only disable drivers, i tried this and it worked. It is recommended for troubleshooting this...

    You can try click on update on your sound driver in device manager, under sound, video and game controllers, it should be called realtek(R) audio, than browse my computer for drivers, let me pick from a list... Choose high definition audio, this will install microsoft OEM audio drivers.

    Also head intel sata drivers can cause that, you can try install standard sata ahci controller, or how it calls by the same method above. There is only one other driver, can't miss it.

    Also i disable nvidia hd audio driver, cause i don't use it! And also uninstall unused drivers, if you click in device manage options or something - show hidden devices, but careful. Or use mokachi driver store util. No chance you changed motherboard, but didn't reinstall system??? This is also important to reinstall, or to at least delete previous drivers, which can cause problems!

    Also i disabled nahimic services and realtek universal audio services in taks manager/services. And i disabled every software driver in device manager related to realtek.

    USB sound cards are trash and cause high dpc latency and increadible input lag. Also make sure you have disabled usb power savings in power plan setting and in device manager under each hid device /mouse/keyboard/all usb controllers etc. Disable hid services in services.msc if you are not using anything which needs it (incredible input lag).

    Also unplugg all other usb devices, if any! Disable usb ports you are not using! Disable everything in bios, which is unnecessary! U can find what is what in bios manual.

    You can download latencymon to check for high dpc latency. Leave it a least 5 minutes and do nothing on your pc.

    You can try download timer resolution, decreases dpc latency and improves mouse delay and even cpu usage.

    Who uses high performance hehe? Even better is ultimate performance and google how to disable idle saver, but check temps and don't use this on laptop. Also disable turning off disks - wears down ssd and not sure if high performance plan turns even hipm to active! Process lasso good program to change power profile automatically and to disable idle saver, or even to change core parking. Also improves system responsiveness by lowering priority, core affinity of other processes.

    U can try to disable hpet in bios, or in device manager. And disable legacy usb support, some usb devices don't have to work. And disable also fast boot in bios! Or memory fast boot.

    Disable dynamic tick , google it! Causes mouse acceleration and is bad for applications too.

    Check if you have enough ram and put page file on ssd, i have 16GB and still need page file, as windows suffers from memory leak. Put it to system managed. Or at least 800-3200.

    Don't think this is notebook but windows can actually put sound card (and pretty much any device) to the sleep to save power and transition between active state and unactive can cause dropouts possible cracking noise. DOn't remember command, there is command for this in cmd for power plan setting.

    Check in device manager, if there is option under your sound drivers, power saving or something , uncheck power down device to save energy, or something. Otherwise it may be possible to change in registry for some audio codecs, check your mobo website for what codec u using. But since u said it happens even without onboard sound card, doubt that's it.

    Also not all usb ports deliver same power, u can check somewhere forget where. And not all ports are meant for high performance devices, check manual!

    Also disable in bios c states for cpu!

    Disable hibernation powercfg -h off in cmd as admin, if you didn't.

    Damn had another idea and i forget it

    Also processes should be set to normal priority, some games set itself to high and cause stuttering,or else. Cpu and windows is good at scheduling, setting processes to high has no benefit, if you don't do other things on pc at the same time, in that case you can lower other process priority.

    Also use pci-e gen 4 if you have z490, or you can try 3. And check in gpu-z after clicking on stress test, your pci-e version.

    Use optimal performance under global 3d options, in nvidia driver and for apps prefer maximum performance.

    Also unbloat windows from pre-installed appx-packages, except store. And disable everything in programs and features, except framework, if you are not using anything. Also disable service sysmain and windows search, if you not using it. And you can disable pagingexectuive, if you have enough ram. Keeps windows kernel in ram.

    U may also want to check eventlog, if they aren't some problems with drivers, or system.

    U can try also memtest, it will check even cpu.

    Check for lose cables, or busted capacitators on motherboard.

    It worst case, this can be caused by bad grounding in house. UPS should be help.

    I also read on some sound site, that you should set approximately same volume in windows as in headphones, that setting it differently can even damage speakers - don't know if it is truth. On other sound site i heard : you should always set 100% in software, otherwise some frequencies won't play. I used 100% since forever and had no problem. This also didn't help for cracking for me...

    WHY THIS SITE is loading so slow, i have pain in my brain from it...
    Last edited by empleat; 10-24-2020 at 01:42 PM.

Page 3 of 3 FirstFirst 1 2 3

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •