Results 1 to 3 of 3
  1. #1
    ROG Junior Member Array
    Join Date
    Aug 2018

    Lightbulb Maximus XII Formula Z490 + Samsung NVMe M.2 (Urgent help needed!)


    Pardon the location, but it is up for general discussion.

    I will reward YOU if you can assist me with my issue.

    Purchased a new Pc rig.
    - ASUS ROG Maximus XII Formula Z490
    - 2x Samsung 970 EVO NVMe M.2 Internal SSD

    Standard CPU cooler from NZXT, a pretty good GPU, decent amount of ram. Got my machine up and running!

    Goal Get both of my NVMe M.2's working as independent partitions. Windows won't recognize my secondary one! Is it faulty?

    1. Installed 1x NVMe M.2 in slot M2_1. No issues, installed windows.

    2. Installed necessary ALL necessary drivers, completed a BIO updated and installed some Intel Rapid Storage Technology.

    3. Pc working! Running! Installed another NVMe M.2 in slot M2_2.

    Let's try a trick that is weird..

    4. Boot, and check Device Manager seems to be reading both M.2's

    5. Check Disk Management, no secondary drive for me to format.. weird?

    6. Boot into Windows Installation, can't seem to format the drive there.. weird?

    Check back my BIOS, Intel Rapid Storage is enabled. Running both drives in what I believe is Raid.

    I don't want that, I disabled Intel RST. Double check within the BIOS, both M.2's appear under "Storage Information"

    7. Boot back into Windows, can't detect the storage in Disk Management

    Again, only see it when I check Device Manager, clearly it's installed and put in together.

    **I have tried swapping their positions, booting them individually. Nothing.
    **I have tried Enabled and Disabling CSM. Nothing.
    **I have tried putting said M.2 inside my other PC, same issue, BIOS can recognize that's it's plugged in, but Windows doesn't.

    I have one Sata being used for my CPU cooler pump, that's all.

    Please! Help. Me. $50 Reward deliver in whatever method your heart desires.
    Last edited by BoyDuddus8; 10-07-2020 at 02:54 AM.

  2. #2
    ROG Guru: Brown Belt Array MrAgapiGC PC Specs
    MrAgapiGC PC Specs
    MotherboardAsus Maximus XI Code
    Memory (part number)CMK32GX4M4B3600C18
    Graphics Card #1STRIX-GTX1080ti-O8G-GAMING
    MonitorAOC AGON AG2701QX (2)
    Storage #1Samsung 960 EVO 256GB
    Storage #2Kingston Savage 500GB
    CPU CoolerNzxt X74 360mm AIO
    CaseNzxt H700
    Power SupplyEVGA 850 G2
    Keyboard Logitech G810
    Mouse Asus Spartha
    Headset Hyper X Cloud Revolver S
    Mouse Pad Hyper X Fury S 900mx420mm
    Headset/Speakers Logitech Z337
    OS Windows 10 64btis
    Network RouterTpLink Archer C9
    Accessory #1 EKWB FANs all of them
    MrAgapiGC's Avatar
    Join Date
    Nov 2011

    Learn, Play Enjoy!

  3. #3
    ROG Member Array
    Join Date
    Jul 2013

    Have you installed the Native Samsung NVMe M.2 drivers instead of the Windows Drivers? Usually solves all those issues including temperature of the drivers.

    Scroll down to Drivers

    Hope that helps.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts