Results 1 to 2 of 2
  1. #1
    ROG Member Array Arkhen's Avatar
    Join Date
    Dec 2013
    Reputation
    10
    Posts
    22

    Question USB 2.0 devices no longer picked up in 3.0 hubs

    Windows 10, version 2004 (19041.508)

    Motherboard: Asus Rampage V Extreme (latest BIOS)

    On a fresh Windows 10 installation, fully updated, I'm completely unable to use my USB 2.0 devices in my 3.0 slots.
    I've installed all the latest drivers on the official Asus page for my motherboard, but I still have this error in my Device Manager, and it still doesn't work.

    - https://www.asus.com/Motherboards/RA...Desk_Download/

    This system has worked fine for years, but suddenly I have these issues, and I suspect it's software related.

    Any help is much appreciated!

    Click image for larger version. 

Name:	imageproxy.png 
Views:	0 
Size:	50.4 KB 
ID:	86477

  2. #2
    ROG Enthusiast Array PipJones PC Specs
    PipJones PC Specs
    MotherboardAsus Rampage V Extreme
    ProcessorIntel® Core™ i7-6900K @ x45 CPU / x36 Cache / AVX -2
    Memory (part number)Corsair Vengeance® LPX 16GB (4 x 4GB) [CMK16GX4M4B3600C18] @ 3400 15-16-16-33
    Graphics Card #1nVidia GTX1080ti FE with EK W/C
    MonitorIiyama G-Master [GB2888UHSU]
    Storage #1Samsung 970 EVO Plus 500 GB PCIe NVMe [MZ-V7S500]
    Storage #24x HGST HTS721010A9E630 1TB 2.5" 7K1000 SATA 3 7200rpm (RAID 10)
    CPU CoolerCustom EK Loop
    CaseCorsair 900D [CC-9011022-WW]
    Power SupplyCorsair AX1200i [CP-9020008-UK]
    Keyboard Corsair Raptor K30 Gaming Keyboard [CH-9000043-UK]
    Mouse Corsair M65 PRO RGB FPS Gaming Mouse [CH-9300011-NA]
    Headset Corsair VOID RGB ELITE USB [CA-9011204-EU]
    OS Windows 10/64
    PipJones's Avatar
    Join Date
    Apr 2015
    Reputation
    10
    Posts
    73

    I think the Asus drivers are quite old now. Try getting the latest intel ones?

    I'm still using my RVE and did a fresh W10 install recently. I have updated to the latest 20H2 build too. I am not using any drivers downloaded from the asus website. I appreciate that it doesn't help your situation, but, it should demonstrate you don't need the asus drivers?

    The only USB2.0 devices that I'm using are mouse and keyboard, they are working. Ports closest to the PS2 port.

    This is a great USB debug tool, might give you a few more clues as to what is going on?

    https://www.nirsoft.net/utils/usb_devices_view.html

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •