Results 1 to 2 of 2
  1. #1
    New ROGer Array
    Join Date
    Oct 2020
    Reputation
    10
    Posts
    2

    Strix G17 Poor FPS - solved

    Good evening.

    I recently purchased my ROG Strix G 17. It has the i7-10750H 16GM Ram and the GTX 1660ti.
    I was really looking forward it being much better than my previous Lenovo with RYZEN 7 3600 and the VEGA10 gpu.

    I play World or Warcraft almost exclusively. With my old rig I ran on 7 or 8 (out of 10) with View Distance maxed out and would run 50-70 FPS consistently even during Raids.

    With my new one, I have it set on 6, just with recommended setting and on the Retail version of WOW I get 30-40 FPS, and in the Public Test Realm I only about 20fps.

    I have uninstalled all the drivers and re-installed them, tried rolling back to previous drivers, and nothing that I do improves it all.
    According to UserBenchmark I should be on Ultra (10 out 10) and getting close to 200 fps.

    Nvidia GTX 1660 Ti (Mobile)
    26,963 User benchmarks, average bench 61%
    Asus(1043 197F) ≥ 4GB
    CLim: 2100 MHz, MLim: 3000 MHz, Ram: 6GB, Driver: 456.71
    Performing way above expectations (95th percentile)
    69.4%
    Good
    Lighting 283
    Reflection 238
    Parallax 263
    74% 261 fps
    MRender 223
    Gravity 240
    Splatting 177
    70% 214 fps

    Can anyone give me any suggestions of what I may be doing wrong? ( I have played on the internal monitor, on the HDMI and USBc connections and they all perform the same.

    I know it has to be something stupid silly that I am just missing but I am litterally tearing my hair out and screaming at it as the poor FPS has cost me PVP matches and to be kicked from raids.

    Thank you in advance for any help.

  2. #2
    New ROGer Array
    Join Date
    Oct 2020
    Reputation
    10
    Posts
    2

    Cool

    So for my issue it was something silly and simple. It appears that if you have the Max Frame Rate set to Off under the Manage 3D Settings in the NVIDIA Control panel then it was set at a default of 58 as the max...
    set it to 1000 and now on Ultra I am getting 110-130.

    Thank you all.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •