Results 1 to 8 of 8
  1. #1
    ROG Enthusiast Array
    Join Date
    Nov 2014
    Reputation
    10
    Posts
    53

    G731GW Lost undervolt ability after recent Win10 updates, cannot roll back

    Hi all, I've been fairly reasonable with allowing windows to update itself when necessary (win 10 64 bit) but yesterday it applied some chipset and intel drivers that rendered both XTU and throttlestop useless, as even if I set an undervolt profile in throttlestop, it no longer does anything (confirmed in HWMonitor).

    I've obviously tried rolling back the updates but windows was unable to, 3 times. More so, it seems to have deleted a restore point I created a while back, so that's rather annoying.

    Did anyone get the same issue? I'm again reaching 92+C temperatures, which I'm not happy with...

    Laptop is a a G731GW, i9750h CPU, 2070 RTX.

    Thanks in advance.
    Miniatura de Adjuntos Miniatura de Adjuntos no undervolt.jpg  

    win updates.PNG  


  2. #2
    ROG Guru: Yellow Belt Array
    Join Date
    May 2011
    Reputation
    22
    Posts
    141

    At the top middle of the ThrottleStop FIVR window it shows, FIVR Control - Locked. Good bye CPU voltage control. This also locks the turbo ratio limits so you cannot adjust those either.

    Some laptops become unlocked after you do a sleep resume cycle. Give that a try and reopen the FIVR window to see if ThrottleStop still shows your CPU as locked.

    Use CPU-Z to see what BIOS version you are using. Try going back to a previous version if you can.

  3. #3
    ROG Enthusiast Array
    Join Date
    Nov 2014
    Reputation
    10
    Posts
    53

    Doh! I completely missed the locked part

    As far as I can tell, it didn't do a BIOS update, I am still on the same 308 as I have been since May. One of those updates must've messed up somehow, but I don't have another BIOS version to revert back to and I'm sure I've been on 308 all this time. Did the sleep cycle, a restart, a hibernate and a forced shutdown, no change.
    Intel/Asus really messed this one up for me. XTU shows the same greyed out options, as expected...

    I can't even find an archive for older BIOS'es though I don't really see how it could help in this case. I've also uninstalled the chipset drivers, still no result. I'm at a loss here :/
    Miniatura de Adjuntos Miniatura de Adjuntos BIOS308.PNG  


  4. #4
    ROG Enthusiast Array
    Join Date
    Nov 2014
    Reputation
    10
    Posts
    53

    Seems like it was the 308 BIOS in the end. Reverted back to 307, disabled the System Firmware check from device manager and I can undervolt happily again. Woohoo!

  5. #5
    ROG Guru: Yellow Belt Array
    Join Date
    May 2011
    Reputation
    22
    Posts
    141

    If it was not a BIOS update then it was a microcode update. The ThrottleStop FIVR window to the right of the PowerCut command will show you what microcode version your CPU is using. Your recent Windows Update likely changed this file which has blocked CPU voltage control.

    The microcode update file can be found in this folder:

    C:\Windows\System32

    The update file is called

    mcupdate_GenuineIntel.dll

    Some users have deleted this file, rebooted, and got CPU voltage control back. Other users have found an older version of this file stored on their computers. If you do a search for mcupdate in the C:\Windows folder, you should be able to find 2 or 3 versions of this file. Swap an older version of this file into the System32 folder, reboot and see what happens.

    I took ownership away from Windows for this file. This prevents Windows from making any future changes to this file without my permission. Creating a system restore point before you do anything like this would be a great idea.

    This used to work but I have not had to do this recently so you are on your own from here. Do a Google search about this file and you should be able to find some more info from other users that have had to do this to restore voltage control. If you delete this file, keep a backup copy handy somewhere so you can restore it if you ever need to.

    Edit - Just read your updated post. Glad you got it working again. Keep my info for future reference.

  6. #6
    New ROGer Array
    Join Date
    Jan 2020
    Reputation
    16
    Posts
    103

    Windows update just decided to update my BIOS form .307 to .308 and kept on updating it on every restart, besides I was manually reverting to .307. What I did was to navigate to C:\Windows\Firmware\{many symbols, blah, blah blah}\ and erased the .308 file. No problem afterward.

    The way I solved such issue on my laptop.

  7. #7
    ROG Enthusiast Array AlexF PC Specs
    AlexF PC Specs
    Laptop (Model)G750JX
    MotherboardASUSTek COMPUTER INC.
    Processori7-4700HQ @2.4GHz OCD to 3.59GHz (-80.1 mV) :)
    Memory (part number)32 GB 1867 MHz Crucial Ballistic (8X4) DDR3L
    Graphics Card #1NVIDIA GeForce GTX 770M 3.0 GB (Tweaked to 932 MHz & 5600MHz)
    Monitor17" (G750JX) + 43" Hisense
    Storage #1SSD Crucial 512GB CT512MX100SSD1
    Storage #2HDD ST1000LM024 1 TB
    OS WIndows 10

    Join Date
    Jan 2014
    Reputation
    10
    Posts
    38

    Hello UnckleWebb:

    I have tried deleting the file mcupdate_GenuineIntel.dll but the system does not allow me. Do you think of another option for returning back the Undervolting feature?

    By the way, the TURBO RATIO LIMITS cannot be edited! (see photo). Should this be related to the same new Windows 10 Update?

    Regards,


    AlexF

    Click image for larger version. 

Name:	Sin título.jpg 
Views:	0 
Size:	184.7 KB 
ID:	86583

  8. #8
    ROG Guru: Yellow Belt Array
    Join Date
    May 2011
    Reputation
    22
    Posts
    141

    You have to take ownership of the mcupdate file away from Windows before you can delete it.

    When CPU voltage control is locked, the turbo ratios are also locked. Your BIOS is not setting these correctly. They should not be all zero.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •