Results 1 to 10 of 10
  1. #1
    ROG Guru: Yellow Belt Array Desertum_0's Avatar
    Join Date
    Mar 2013
    Reputation
    13
    Posts
    145

    ASus Raid DLX : The digital signature of the object did not verify

    Hey guys,

    I re installed a clean windows 10 pro 20H2 version and every time I want to install the Strix setup drivers and software for my sound card I get this issue.

    I can see the Asus Strix DLX on the device manager and it is working, I can hear the sound coming out of my 5.1 speakers.

    Click image for larger version. 

Name:	strix.jpg 
Views:	0 
Size:	60.7 KB 
ID:	86554

    I am also using the latest ASMedia USB 3.0+3.1 Drivers & Software Set v1.16.61.1 WHQL and the box link firmware been updated to the latest long time ago.
    I have had any issue with this card and windows 10 until today, perhaps I need to re install windows again or maybe the asus drivers are not up to date anymore?

    Any help would be highly appreciated.

  2. #2
    New ROGer Array
    Join Date
    Sep 2018
    Reputation
    10
    Posts
    2

    I have the same issue, decided to upgrade to the latest drivers today and all failed, even the roll back driver. Doing a google search a few people have indicated that ASUS have let the software licensing with MS run out, so windows will not install the driver. Looks like we just must suck it up until someone gets there finger out and pushes this through. MS are not quick at this either.

  3. #3
    ROG Junior Member Array
    Join Date
    Dec 2013
    Reputation
    10
    Posts
    1

    I have the same problem with 2 sound boards.
    Asus xonar u7 mkii and with Asus STRIX RAID DLX
    I uninstalled the MKII driver with ganudl to install the Strix and when installing the driver I received the error THE DIGITAL SIGNATURE OF THE OBJECT DID NOT VERIFY
    And in the end I gave up and returned to MKII but unfortunately I get the same error this time ..
    Someone knows a solution

  4. #4
    New ROGer Array
    Join Date
    Oct 2020
    Reputation
    10
    Posts
    1

    same problem

    my Asus STRIX RAID did same so i got new ae card and same again so spent money i did not need to thanks to asus being so bloody lazy and not renewing there license with microsoft

  5. #5
    New ROGer Array
    Join Date
    Aug 2020
    Reputation
    10
    Posts
    7

    Don't buy

    WARNING
    Anyone thinking of buying a Asus sound card then don't.
    It's been months of problems without Asus even acknowledging the problem, so don't touch it until they fix the drivers.
    I'm fortunate that I didn't uninstall my drivers in a attempt to get my Strix Raid Pro working ie it will not startup when windows boots.
    But I can start it up manually a few minutes after.

  6. #6
    ROG Member Array Red Butterflies PC Specs
    Red Butterflies PC Specs
    MotherboardAsus Z170 Pro Gaming
    Processorİntel İ7 6700K
    Memory (part number)Kingston 2X8 2133MHZ DDR4
    Graphics Card #1Asus Strix Gtx1060 6Gb
    MonitorSamsung 24" Full HD 60HZ
    Storage #1Samsung 850 Evo 250GB
    Storage #2Seagate 1 TB SATA 3
    CPU CoolerCooler Master Hyper 212 Evo
    OS Windows 10 Home
    Red Butterflies's Avatar
    Join Date
    Jan 2018
    Reputation
    10
    Posts
    15

    hello i found the source of the problem.
    windows 10 KB4579311 uninstalling this update, restarting the computer and installing xonar mk ii driver

    Temporary solution until asus releases update

  7. #7
    ROG Member Array Red Butterflies PC Specs
    Red Butterflies PC Specs
    MotherboardAsus Z170 Pro Gaming
    Processorİntel İ7 6700K
    Memory (part number)Kingston 2X8 2133MHZ DDR4
    Graphics Card #1Asus Strix Gtx1060 6Gb
    MonitorSamsung 24" Full HD 60HZ
    Storage #1Samsung 850 Evo 250GB
    Storage #2Seagate 1 TB SATA 3
    CPU CoolerCooler Master Hyper 212 Evo
    OS Windows 10 Home
    Red Butterflies's Avatar
    Join Date
    Jan 2018
    Reputation
    10
    Posts
    15


  8. #8
    New ROGer Array
    Join Date
    Aug 2020
    Reputation
    10
    Posts
    7

    Quote Originally Posted by Red Butterflies View Post
    hello i found the source of the problem.
    windows 10 KB4579311 uninstalling this update, restarting the computer and installing xonar mk ii driver

    Temporary solution until asus releases update
    As I understand it this is a work around to be able to reinstall the drivers ?
    Will this help my problem where my Strix Raid Pro card isn't detected ie it doesn't start up when windows boots ?
    nhAsusStrixUILauncher, nhAsusStrixSvc32 and nhAsusStrixSvc64 are all running but sonic studio if opened will say no card detected, if I kill these 3 tasks and wait a minute or two and then run nhAsusStrixUILauncher all works as usual.

    This started happening well before the release of KB4579311 for myself and a friend, the only difference between us is I didn't uninstall the drivers and have managed a work around where as my friend did uninstall and got the licencing error when they tried to reinstall.

  9. #9
    New ROGer Array
    Join Date
    Sep 2018
    Reputation
    10
    Posts
    2

    Quote Originally Posted by Red Butterflies View Post
    hello i found the source of the problem.
    windows 10 KB4579311 uninstalling this update, restarting the computer and installing xonar mk ii driver

    Temporary solution until asus releases update
    I can confirm that this solution works for me. Many Thanks Red Butterflies.

  10. #10
    ROG Member Array
    Join Date
    Jun 2018
    Reputation
    10
    Posts
    9

    I can't delete KB4579311, error appear.
    The problem is that this update disabling SHA-1
    Why Asus so lazy? How to fix that issue?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •