Results 1 to 7 of 7
  1. #1
    New ROGer Array
    Join Date
    Dec 2019
    Reputation
    10
    Posts
    2

    Maximus XII Formula OLED Display issue? Flickers every 3 seconds WHY? [Resolved]

    Hi, just bought a Maximus XII Formula Z490 as part of my new build. I am running the latest version of Windows 10 Pro and have all the latest drivers, armoury crate (3.1.6.0), etc. I’m running BIOS 0707. I’m having the following issues:

    1. The OLED display always flickers every 3 seconds. When it flickers, it basically switches itself off very briefly and is quite noticeable.

    Is it because of the new BIOS (0707), or has it always been like that? Is that a protection so that nothing burns itself into the display? How can you turn off the flicker?

    I appreciate any help .

    Cobi

  2. #2
    New ROGer Array
    Join Date
    Jun 2020
    Reputation
    10
    Posts
    23

    I have the same problem as you, but I cannot access the OLED screen configurator and it always shows only the cpu temp.

    I was hoping they would correct it, but it's been so long that they don't fix it. To be a Top product and that it is a new one, it is disappointing me a lot

  3. #3
    ROG Member Array
    Join Date
    Aug 2014
    Reputation
    10
    Posts
    11

    I have the same problem
    This is what I know when BIOS 0707 was installed I believe it also updated oled screen firmware and that's when it started for me right after. It was 100% flicker free for months before in fact from release day for me. My guess is even if you go back to an older bios after it will not undo the firmware for the oled.
    so until Asus at least acknowledges they screwed this up and fix it not much we can do.

  4. #4
    ROG Member Array
    Join Date
    Aug 2014
    Reputation
    10
    Posts
    11

    GanjaHouse I had the problem of "cant access the OLED screen configurator" on my previous gen formula when I used the standalone install of LiveDash. I removed Aura service from control panel and live dash then installed Armoury Crate and controlled the oled from within Armoury Crate worked great after that.

  5. #5
    New ROGer Array
    Join Date
    Jun 2020
    Reputation
    10
    Posts
    23

    Quote Originally Posted by Republic of Pax View Post
    GanjaHouse I had the problem of "cant access the OLED screen configurator" on my previous gen formula when I used the standalone install of LiveDash. I removed Aura service from control panel and live dash then installed Armoury Crate and controlled the oled from within Armoury Crate worked great after that.
    Yes, that is what I did and I have the same result.
    I have deleted all traces in the registry and after reinstalling only the armory crate, I have the same problem and can never access the OLED screen.

    I'm using the latest windows 10 update, latest Nvidia drivers and all updated drivers.

  6. #6
    New ROGer Array MooMcKnight PC Specs
    MooMcKnight PC Specs
    Laptop (Model)MS Surface Pro 4 I7, 256GB, 8GB
    MotherboardAsus Rog Crosshair VII Hero (wi-fi)
    ProcessorRyzen 9 3900x
    Memory (part number)XPG D60G RGB 16GB 3200MHz
    Graphics Card #1Red Devil Radeon RX 5700 XT
    Monitor65 inch QLED TV through Dolby Atmos surround system
    Storage #1addlink S70 2TB SSD NVMe
    Storage #2TEAMGROUP Delta MAX RGB SSD 1TB
    CPU CoolerAsus ROG Ryujin 240
    CaseLian Li o11 dxl
    Power SupplyThermaltake Toughpower Grand RGB 750W 80+ Gold
    Keyboard Steelseries Apex 7
    Mouse Steelseries Rival 650
    Headset n/a
    Mouse Pad Steelseries QcK Prism RGB
    Headset/Speakers Samsung HW Q90R 7.1.4
    OS Windows 10 Home 64bit
    Network RouterNetgear Nighthawk RAX80
    Accessory #1 Nyan Cat
    Accessory #2 Bongo Cat
    Accessory #3 (animations for oleds on accessories!)

    Join Date
    Jul 2020
    Reputation
    10
    Posts
    4

    Same problem here on ryujin cooler oled. Now after last BIOS update on my Hero VIII MB, I'm stuck with broken then forcibly removed armoury crate, and a stuttering test image that flickering as you have described in the middle of the animation. So, I guess they broke all their screens.

  7. #7
    ROG Member Array
    Join Date
    Aug 2014
    Reputation
    10
    Posts
    11

    Fixed

    This has been fixed for me on the Maximus Formula XII OLED with the latest Bios update ver 0805 2020/11/09.
    As part of the Bios update the Bios flashes the motherboard OLED Firmware and the problem is 100% fixed no more flashing OLED.
    Click image for larger version. 

Name:	20201111_112925.jpg 
Views:	0 
Size:	110.1 KB 
ID:	86807

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •