Results 1 to 3 of 3
  1. #1
    New ROGer Array
    Join Date
    Dec 2018

    Z2EA will not boot, mb has pwr, START doesn't pwr on & pwr button doesn't pwr on

    Hi everyone. I have an issue with a system that has stumped me. Here's the system's specs:
    Mb: Z2EA
    RAM: CMW64GX4M8C3000C15
    CPU: 3990X
    Cooler: Thermalright Silver Arrow TR4
    GPU: TUF GTX 1660 Super
    PSU: Corsair AX1600i
    Case: Corsair Obsidian 1000D
    Storage: 4 x Sabrent Rocket 2TB PCIe 4 - 2 on the board, 2 in the DIMM 2 slot
    I also have 2 Corsair Commander Pros and 2 Corsair RGB hubs for the fans (10 x Corsair LL120s, 3 x LL140s)

    So, the issues are that the case power button doesn't boot the system, nor does the START button on the mb despite getting the initial RGBs and display on the top left of the mb to animate. I've triple checked the fp connectors, all of the mb power is secure on both ends, I know the GPU is working, tried 1 and also 8 RAM stick config according to the Z2EA manual. I'm at a loss as how to proceed forward. There are no active QLEDs either.

    Any help or advice would be greatly appreciated. Thanks.
    Last edited by Camco; 10-29-2020 at 11:54 AM. Reason: added 'QLED'

  2. #2
    ROG Guru: Grand Master Array Arne Saknussemm PC Specs
    Arne Saknussemm PC Specs
    Laptop (Model)Laptop?...No way! (Model?...Jun Amaki...yes way!)
    ProcessorTHREADRIPPER 3960X
    Memory (part number)TXBD48G4000HC18FBK
    Graphics Card #1GTX Titan X
    Graphics Card #2SLI is dead to me
    Graphics Card #3Tri SLI is even dead to Nvidia
    Graphics Card #4Quad SLI is dead to everybody especially my credit card
    Sound CardXonar Essence STX
    MonitorASUS ROG Swift PG279Q
    Storage #1Samsung 970/960/950 PRO
    Storage #22x OCZ VERTEX 3/2x WD Caviar Black 500GB / 2x WD RED 2TB/Samsung 1TBSSDs
    CPU CoolerCustom Loop: Dual D5s, Dual Alphacool Monsta 480s, XSPC Raystorm Neo TR4, EK TitanX WaterBlock
    CaseNope!...Dimastech Easy XL...let it all hang out man!
    Power SupplySeasonic 1000 Platinum
    Keyboard Corsair Strafe MK2 ROG Claymore... or Fender Rhodes Electric Piano (MKI 73)
    Mouse Corsair M65Pro or Speedy Gonzalez...not Mickey...don't do Disney!
    Headset ...firmly on neck
    Mouse Pad Mouse don't got his own pad man...lives with me
    Headset/Speakers Edifier Spinnaker...or you mean the speakers in my too many voices to name them all
    OS Win XP, 7, 8, 8.1 and Windows 10 Spyware Edition
    Network Router56k modem
    Accessory #1 Umm...nice tie?
    Accessory #2 Err...belt?
    Accessory #3 3 accessories?! I'm not a girl!!
    Arne Saknussemm's Avatar
    Join Date
    Apr 2012

    Check the way the board is etc...and if you have a spare PSU check that...check the correct power cables are connected

  3. #3
    New ROGer Array
    Join Date
    Dec 2018

    I appreciate your reply.
    I just recently checked. It came with standoffs preinstalled in the case as well. I have no other spare psu. I also recently removed the cmos battery and also reseated the cpu. None of which worked yet. I hope something is not defective or needs RMA lol

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts