Results 1 to 3 of 3
  1. #1
    New ROGer Array
    Join Date
    Dec 2021
    Reputation
    10
    Posts
    2

    Question Tuf Gaming x570 Plus not showing video

    Hello, first post.

    I bought the MB mentioned in the title with an AMD Ryzen 9 5950x. After the build I powered up and got no video. The white LED lit up, indicating VGA issues.

    I connected the monitor via the HDMI video out. I then tested using a video card and video came up just fine. I know that the mother board's integrated video will work only with processors with the X suffix which mine has. I can use the video card output, but would like to know why I am not getting any video from the MB's HDMI out. Does anyone have any suggestions what I can try to troubleshoot this issue?

    I am thinking of removing the heat sink to verify that the chip says 5950x, although it is clearly marked on the box.

    Thanks for your time and assistance. Saga

    Edit: I looked for 5950 processors and found none. Is there such an item (5950 without the X) ?
    Last edited by SagaHWX; 12-28-2021 at 04:12 AM.

  2. #2
    ROG Member Array uprising PC Specs
    uprising PC Specs
    MotherboardCrosshair vii hero
    ProcessorRyzen 7 5800x
    Memory (part number)Corsair vengeance pro 32gb
    Graphics Card #1RTX 3070
    MonitorAsus PG278QR
    Storage #1x6 ssd
    Storage #2x2 hdd
    Power SupplyAX1200
    OS WIN 10 PRO

    Join Date
    Nov 2013
    Reputation
    10
    Posts
    17

    Hi you’ve got it the wrong way around cpu with X don’t have a IGPU only cpu with G like the 5700g & 5600g.

  3. #3
    New ROGer Array
    Join Date
    Dec 2021
    Reputation
    10
    Posts
    2

    TUF Gaming x570 Plus not showing video

    Quote Originally Posted by uprising View Post
    Hi you’ve got it the wrong way around cpu with X don’t have a IGPU only cpu with G like the 5700g & 5600g.
    Dang, that's the second time I got it wrong! Only down side is I paid for video out hardware on the MB for a uP that does not have integrated graphics. Luckily, I have an extra video card I can use for this build.

    Thanks for clearing this up, I appreciate it. Saga

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •