Page 2 of 2 FirstFirst 1 2
Results 11 to 15 of 15
  1. #11
    New ROGer Array
    Join Date
    Nov 2020
    Reputation
    10
    Posts
    4

    I tried to follow the steps here (I assume they realise their **** is broken) https://www.asus.com/events/infoM/ac...-ops-cold-war/ but then of course, I get another error following the steps about the initial error lol "vBulletin Message Unrecognized URL (https://www.asus.com/)".

  2. #12
    New ROGer Array
    Join Date
    Oct 2020
    Reputation
    10
    Posts
    1

    Same issue here

    Hi, same case here, how did you contact them?

    Thanks

  3. #13
    New ROGer Array
    Join Date
    Nov 2020
    Reputation
    10
    Posts
    4

    Ok, so for EVERYONE who hasn't yet figured this out - you need to go to my previous post in this thread and go to the COD CW link I left, which will tell you to msg the admin on these forums. You give the required information then hit send, and an error comes up in the forums saying invalid URL www.asus.com or some ****. Despite the error, it still reaches them because they just sent me the code 4 days later.

  4. #14
    New ROGer Array
    Join Date
    Nov 2020
    Reputation
    10
    Posts
    1

    Not able to redeem

    I'm having the same issues. (Country error on page, then URL issue in the form)

    I also did the submission, but haven't received a code and it's been a few weeks now.

    Wish I could get some kind of communication.

  5. #15
    New ROGer Array
    Join Date
    Nov 2020
    Reputation
    10
    Posts
    1

    Yeah I submitted via the forum message last week and got the invalid URL error. Haven't heard anything yet. I also noticed there was nothing in my sent messages so I've just tried again and this time it said the message was successfully sent.

    Such a painful process from ASUS.

Page 2 of 2 FirstFirst 1 2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •