Results 1 to 2 of 2
  1. #1
    New ROGer Array
    Join Date
    Nov 2019
    Reputation
    10
    Posts
    72

    Question Windows doesn't me install USB Root HUB driver, when not using USB 3.0

    Hey,

    when i enable even one USB 3 port in BIOS, i can feel that my mouse movement lags! Problem is that USB Root HUB driver, changes to USB Root HUB (USB 3.0). New motherboards don't have proper USB 2 drivers At least if i could install my driver - driver which was there before (when not using USB 3.0). I will still need USB 3 for VR, but to go into BIOS each time when i want to switch between 2D and VR is too annoying...

    I went into device manager and tried option - let me pick my driver. But it didn't gave me another option. I also tried disk option and put there path to windows/system32/drivers - i checked driver is located there. And it said Windows already determined best driver for your device and doesn't let me change it!

    How would i forced USB Root HUB driver back??? I suspect it cause lag, because USB 3 drivers are known to be laggy, maybe even USB 3 in design is more throughput, but higher latency! Because when i had USB Root HUB, not USB Root HUB (USB 3.0) - mouse didn't lag! Since you have USB 3 ports active, i understand it installs USB Root HUB (USB 3.0), so USB 3 devices will work! But when i am not using them, i don't want USB Root HUB (USB 3.0), as it causes lag!

    Thanks!

  2. #2
    New ROGer Array
    Join Date
    Nov 2019
    Reputation
    10
    Posts
    72

    Anyone BUMP. USB 3 is soo lagged!!!

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •