Results 1 to 4 of 4
  1. #1
    ROG Member Array fatalhalt PC Specs
    fatalhalt PC Specs
    MotherboardROG Strix B550-I Gaming 2003 BIOS
    ProcessorRyzen 7 5800X
    Memory (part number)G.SKILL F4-3200C14-16GTRS
    Graphics Card #1Nvidia GeForce RTX 2070 Super
    Storage #1Firecuda 520 1TB PCIe NVMe 4.0
    Power SupplyCorsair SF750

    Join Date
    May 2018

    B550-I Ryzen 5800X: DtsApo4Service.exe crashes (Sonic Studio 3 effects not working)

    Hello guys,

    I have a following new build:

    AMD Ryzen 7 5800X
    ROG Strix B550-I Gaming
    Windows 10 20H2 (19042.630)

    I have been fighting with trying to get Sonic Studio 3 effects working and the experience so far has been unbearable and painful.

    - the audio doesn't work unless I check "Disable All Sound Effects" in Realtek Audio Console, but when I do this then I can't use Sonic Studio 3 effects...
    - I have tried clean reinstalling Asus audio drivers without any luck, still can't get Sonic Studio 3 effects working
    - I have tried clean installing MoKiChU's AUDIO_Realtek_UAD_ASUS_ROG_SS3-DTS_MB_v6.0.9047.1.7z which at least made my sound continue working without needing to "Disable All Sound Effects", but any changes made to EQ/effects in Sonic Studio 3 are taking any effect. While MoKiChU driver pack worked for a moment , soon I have been back to square one with sound not working again unless I check "Disable All Sound Effects"

    I'm trying to understand if my problems are related to DTS APO4x not being fully functional (the DtsApo4Service.exe is unable to start). I know that Sonic Studio 3 depends on Nahimic service/driver, but is that true with DTS APO4x?

    DtsApo4Service.exe crashes whenever Windows 10 starts, or whenever I try to manually start it:
    Faulting application name: DtsApo4Service.exe, version:, time stamp: 0x5e4f3765
    Faulting module name: dtscnt64.dll, version:, time stamp: 0x5ea9603d
    The DtsApo4Service service terminated unexpectedly.
    I have tried to manually start:
    > cd C:\Windows\System32\DTS\PC\APO4x\
    > DtsApo4Service.exe -console
    it crashed and prints:
    CPUBITS 0x3ff

    C:\Windows\System32\DTS\PC\APO4x>DtsApo4Service.exe -console
    4: Running in console mode. Press enter to start.
    4: Starting Rpc Server..
    4: DtsApoService in OnStart
    4: Press enter to stop the server and exit.
    CPUBITS  0x3ff
    Has anyone experienced crashing DtsApo4Service.exe? Could this be related to AVX instruction on Ryzen 7 5800X?

  2. #2
    ROG Enthusiast Array huppra PC Specs
    huppra PC Specs
    MotherboardCrosshair X670e Hero
    Memory (part number)F5-6000J3038F16GX2-TZ5NR
    Graphics Card #1Nvidia 4090 FE
    Sound CardGo XLR
    MonitorAcer X34 GS, XCB271HU
    Storage #1Samsung 980 Pro, WDS100T3X0C, 2xMP510
    Storage #2Samsung 850x3
    CPU CoolerEK 360 AIO
    CasePC-O11 D XL ROG
    Power SupplyCorsair ax1600i
    Keyboard Dygma Raise
    Mouse Glorious Model D-
    Headset Sennheiser HD 6XX
    Headset/Speakers JBL LSR305
    OS Windows 11 Pro 2H22
    Accessory #1 Elgato Ring Light
    Accessory #2 Elgato Stream Deck
    Accessory #3 Logitech Brio

    Join Date
    Aug 2016

    I'm on not Ryzen but a 10900k with the Asus Maximus XII Hero /Wifi and have started having this error pop up as of today, which is 2 days after a complete clean install without this error. I've tried completely reinstalling the realtek drivers, uninstalling and even disabling it bios after removing the drivers and I'm still getting this error.

  3. #3
    ROG Junior Member Array
    Join Date
    Nov 2015

    Same problem with a 10850k and Maximus XII Hero

  4. #4
    ROG Guru: Green Belt Array MoKiChU PC Specs
    MoKiChU PC Specs
    MotherboardASUS ROG Strix Z370-F Gaming
    ProcessorIntel Core i7-8700K
    Memory (part number)Corsair Vengeance RGB DDR4 2666MHz CL16 - 16GB (2 x 8GB)
    Graphics Card #1ASUS ROG Strix GTX 1080 Ti OC
    MonitorASUS ROG Strix XG35VQ
    Storage #1SSD NVMe Samsung 970 EVO Plus 500GB
    Storage #2SSD NVMe Samsung 960 EVO 250GB | SSD NVMe Corsair Force MP510 240GB | SSHD AHCI Seagate FireCuda 2TB
    CPU CoolerCooler Master ML240L RGB
    CaseBitFenix Enso
    Power SupplyCorsair TX850M (850W)
    Keyboard Logitech G413
    Mouse Logitech G502
    Headset/Speakers Logitech Z333
    OS Windows 11 Pro 22H2
    MoKiChU's Avatar
    Join Date
    Aug 2013


    Cleanup your audio drivers then install the latest drivers package.

    You have an ASUS ROG SS3|DTS Sound Unbound motherboard, so :

    You need Realtek Audio Drivers (UAD - ASUS ROG SS3-DTS MB) from the first post of this thread : [DRIVERS] Realtek Audio (MB | Intel 2xx/3xx/4xx/5xx & AMD 3xx/4xx/5xx).

    Follow scrupulously your CLEANUP process then your INSTALL process, for the next drivers packages that I would release, you will can directly follow your UPDATE process.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts