Results 1 to 4 of 4

Threaded View

  1. #1
    ROG Member Array fatalhalt PC Specs
    fatalhalt PC Specs
    MotherboardROG Strix B550-I Gaming 2003 BIOS
    ProcessorRyzen 7 5800X
    Memory (part number)G.SKILL F4-3200C14-16GTRS
    Graphics Card #1Nvidia GeForce RTX 2070 Super
    Storage #1Firecuda 520 1TB PCIe NVMe 4.0
    Power SupplyCorsair SF750

    Join Date
    May 2018
    Reputation
    14
    Posts
    22

    B550-I Ryzen 5800X: DtsApo4Service.exe crashes (Sonic Studio 3 effects not working)

    Hello guys,

    I have a following new build:

    AMD Ryzen 7 5800X
    ROG Strix B550-I Gaming
    Windows 10 20H2 (19042.630)

    I have been fighting with trying to get Sonic Studio 3 effects working and the experience so far has been unbearable and painful.

    - the audio doesn't work unless I check "Disable All Sound Effects" in Realtek Audio Console, but when I do this then I can't use Sonic Studio 3 effects...
    - I have tried clean reinstalling Asus audio drivers without any luck, still can't get Sonic Studio 3 effects working
    - I have tried clean installing MoKiChU's AUDIO_Realtek_UAD_ASUS_ROG_SS3-DTS_MB_v6.0.9047.1.7z which at least made my sound continue working without needing to "Disable All Sound Effects", but any changes made to EQ/effects in Sonic Studio 3 are taking any effect. While MoKiChU driver pack worked for a moment , soon I have been back to square one with sound not working again unless I check "Disable All Sound Effects"

    I'm trying to understand if my problems are related to DTS APO4x not being fully functional (the DtsApo4Service.exe is unable to start). I know that Sonic Studio 3 depends on Nahimic service/driver, but is that true with DTS APO4x?

    DtsApo4Service.exe crashes whenever Windows 10 starts, or whenever I try to manually start it:
    Code:
    Faulting application name: DtsApo4Service.exe, version: 1.3.3.0, time stamp: 0x5e4f3765
    Faulting module name: dtscnt64.dll, version: 4.2.7.0, time stamp: 0x5ea9603d
    or
    Code:
    The DtsApo4Service service terminated unexpectedly.
    I have tried to manually start:
    > cd C:\Windows\System32\DTS\PC\APO4x\
    > DtsApo4Service.exe -console
    it crashed and prints:
    CPUBITS 0x3ff
    AVX HIT

    Code:
    C:\Windows\System32\DTS\PC\APO4x>DtsApo4Service.exe -console
    4: Running in console mode. Press enter to start.
    
    4: Starting Rpc Server..
    4: DtsApoService in OnStart
    4: Press enter to stop the server and exit.
    
    
    
    CPUBITS  0x3ff
    
    
    AVX HIT
    
    C:\Windows\System32\DTS\PC\APO4x>
    Has anyone experienced crashing DtsApo4Service.exe? Could this be related to AVX instruction on Ryzen 7 5800X?

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •