Results 1 to 2 of 2
  1. #1
    ROG Member Array
    Join Date
    Apr 2014
    Reputation
    10
    Posts
    16

    Apex Fresh Install, Tons of Device Manager "Other Devices"

    I've just installed windows on my new Rampage VI Apex board and have a ton of "other devices" listed in Device manager. I upgraded the BIOS and the ME Firmware and the PC seems to run well but this is what I get in Device Manager...

    80, yes 80x "Base System Device" items in "other devices, 3x "Performance Counters" and 4x "System Interrupt Controller".

    It's the latest version of Windows 10, updated.
    BIOS 3404
    ME FW : 11.12.86.1877

    Chipset - 10.1.18716.8265
    ME - 2113.15.0.2242

    It also seems that the WIFI device appears in Device Manager when it's switched off in the BIOS.

    Does anyone have any Ideas on how I can sort these issues out?
    Miniatura de Adjuntos Miniatura de Adjuntos OtherDevices1.png  

    OtherDevices2.png  

    Last edited by Dingleweed; 05-08-2021 at 04:03 PM. Reason: Replaced an erroneous image

  2. #2
    ROG Member Array
    Join Date
    Apr 2014
    Reputation
    10
    Posts
    16

    Problem solved. It seems Microsoft have changed the way Windows Update works and there was a load of Optional Driver Updates that I hadn't noticed... I installed them all and all the Unknown Devices went away... strange!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •