Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 27

Hybrid View

  1. #1
    ROG Junior Member Array
    Join Date
    Nov 2016
    Reputation
    10
    Posts
    3

    ROG Delta Version 0144 - Low mic input volume

    I don't want the LED to stay on when I turn off the computer and I don't like to manually switch off the RGB on the headset when I don't use it, so I've turned off Fast Boot in Windows 10 and it powers down the headset when I turn off the computer. With the latest BIOS "Version 0144", the mic input volume is really low when I use it after a boot. The only way to fix the problem is to unplug the USB from the computer (USB C or 2.0, doesn't matter) and plug it back. It works well from there until I shut down the computer. With Fast Boot on, you won't get this issue unless you turn off the PSU switch or unplug the power cord. With Version 0039_beta, I don't get this issue so I'll stick with this version until it gets fixed.

  2. #2
    ROG Guru: Brown Belt Array MrAgapiGC PC Specs
    MrAgapiGC PC Specs
    MotherboardAsus Maximus XI Code
    Processor9900K
    Memory (part number)CMK32GX4M4B3600C18
    Graphics Card #1STRIX-GTX1080ti-O8G-GAMING
    MonitorAOC AGON AG2701QX (2)
    Storage #1Samsung 960 EVO 256GB
    Storage #2Kingston Savage 500GB
    CPU CoolerNzxt X74 360mm AIO
    CaseNzxt H700
    Power SupplyEVGA 850 G2
    Keyboard Logitech G810
    Mouse Asus Spartha
    Headset Hyper X Cloud Revolver S
    Mouse Pad Hyper X Fury S 900mx420mm
    Headset/Speakers Logitech Z337
    OS Windows 10 64btis
    Network RouterTpLink Archer C9
    Accessory #1 EKWB FANs all of them
    MrAgapiGC's Avatar
    Join Date
    Nov 2011
    Reputation
    28
    Posts
    1,853

    i will take a look since i am following these case for a while and is correct and confirm i will pass it.
    Learn, Play Enjoy!

  3. #3
    New ROGer Array
    Join Date
    Nov 2019
    Reputation
    10
    Posts
    4

    I have the exact same problem with the exact same way to fix it. Hopefully they will fix it soon.

  4. #4
    ROG Member Array
    Join Date
    Nov 2020
    Reputation
    10
    Posts
    12

    Quote Originally Posted by MrAgapiGC View Post
    i will take a look since i am following these case for a while and is correct and confirm i will pass it.
    i have problem too, mic not working on ver0144 when i replug usb-c to usb, mic working but headphone not working only mic working interesting issue

    i downgrade 0039_beta

  5. #5
    New ROGer Array
    Join Date
    Aug 2019
    Reputation
    10
    Posts
    1

    any uptade to this Issue ? the mic is very low when I play dota 2, i have to plug and replug every time when I turn on the pc , it's very annoying to do this every day

  6. #6
    New ROGer Array fredengl PC Specs
    fredengl PC Specs
    MotherboardRog Strix B550-F WIFI
    ProcessorRyzen 5600x
    Memory (part number)4x8 crucial 3600
    Graphics Card #1Rog strix rtx 2060
    Monitorlenovo y25-25
    Storage #1980 pro 500go nvme
    Storage #21 to 870 ev sata + 2to 870 qvo sata
    CPU Coolerbequiet
    Caseantec p280
    Power Supplycorsair rm 650X
    Keyboard steelseries apex 3
    Mouse rog chakram core
    Headset Rog delta
    Mouse Pad Steelseries Prism cloth xl
    Headset/Speakers Altec Ada890 THX
    OS Windows 11
    Network RouterAsus RT AC 86U

    Join Date
    May 2021
    Reputation
    10
    Posts
    6

    i have the same question. Can asus answer quickly ? just to know if i continue to pray everyday for a new firmware to avoid the daily unplug replug?

  7. #7
    New ROGer Array
    Join Date
    Feb 2022
    Reputation
    10
    Posts
    4

    Quote Originally Posted by ViPERacing View Post
    I don't want the LED to stay on when I turn off the computer and I don't like to manually switch off the RGB on the headset when I don't use it, so I've turned off Fast Boot in Windows 10 and it powers down the headset when I turn off the computer. With the latest BIOS "Version 0144", the mic input volume is really low when I use it after a boot. The only way to fix the problem is to unplug the USB from the computer (USB C or 2.0, doesn't matter) and plug it back. It works well from there until I shut down the computer. With Fast Boot on, you won't get this issue unless you turn off the PSU switch or unplug the power cord. With Version 0039_beta, I don't get this issue so I'll stick with this version until it gets fixed.
    I have exactly the same problem. With bios version 0144 and earlier, I could downgrade it to 0039 and it could be solved. But recent bios version 0150 realised, and I decided to test it. Unfortunately, the problem with low mic input volume persisted, but now, after new bios installed, I can't downgrade it to any previous versions, presented on the Asus support site (tried 0039_beta, 0045, 0105). When I start USB Audio FW Update Tool there is a message in the status line: "No USB sound" and upper menu is clear and I can't choose my delta headset, but it's 100% plugged and work fine (only low mic input volume, fixed by unplugging plugging back). It's very annoying, please, ASUS, fix this problem asap, or return us the possibility to downgrade headset bios again.

  8. #8
    New ROGer Array
    Join Date
    Nov 2021
    Reputation
    10
    Posts
    1

    Post Please Fix this problem

    If anyone out there still cares about this headset and this issue, please fix this issue. I'm tired of unplugging and plugging the headphone cable. You introduced the best headset in the world but you are not even solving problems.
    My Windows is the latest version, all drivers are up to date, Armory Create is up to date, 0150 bios of the headset is installed. What are we gonna do ? JESUS !

  9. #9
    ROG Enthusiast Array
    Join Date
    Sep 2020
    Reputation
    10
    Posts
    37

    Angry

    Quote Originally Posted by ViPERacing View Post
    I don't want the LED to stay on when I turn off the computer and I don't like to manually switch off the RGB on the headset when I don't use it, so I've turned off Fast Boot in Windows 10 and it powers down the headset when I turn off the computer. With the latest BIOS "Version 0144", the mic input volume is really low when I use it after a boot. The only way to fix the problem is to unplug the USB from the computer (USB C or 2.0, doesn't matter) and plug it back. It works well from there until I shut down the computer. With Fast Boot on, you won't get this issue unless you turn off the PSU switch or unplug the power cord. With Version 0039_beta, I don't get this issue so I'll stick with this version until it gets fixed.
    Same problem for my asus rog delta... Tried everything to get it fix, but with no success.

  10. #10
    New ROGer Array
    Join Date
    Mar 2022
    Reputation
    10
    Posts
    2

    Quote Originally Posted by IvayloStrix View Post
    Same problem for my asus rog delta... Tried everything to get it fix, but with no success.
    So basically, I have a problem with my delta headset. The mic has input only when I HOLD it very close to my mouth, or when I spend 10 minutes to get a position where it gets input.. Really annoying and kinda dissappointing, since this is my favourite headset. I really can't deal with this, since I have online classes very often..

Page 1 of 3 1 2 3 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •