Results 1 to 3 of 3
  1. #1
    ROG Enthusiast Array
    Join Date
    Jan 2019
    Reputation
    55
    Posts
    60

    Vulnerability mitigation seems to cause random reboots and slow performances

    There are 2 known AMD Cpu vulnerabilities for which a change to a registry key is required in Windows to enable/disable the related mitigations, these are:
    - CVE-2017-5715 (Spectre Variant 2)
    - CVE-2018-3639 (Speculative Store Bypass)
    The related registry keys are described here: https://support.microsoft.com/en-gb/...erabilities-in

    On my Crossfire VIII Formula, with an AMD 5900X, if I enable the Speculative Store Bypass mitigation using the following commands from a Powershell (Administrator):
    reg add "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Contr ol\Session Manager\Memory Management" /v FeatureSettingsOverride /t REG_DWORD /d 8 /f
    reg add "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Contr ol\Session Manager\Memory Management" /v FeatureSettingsOverrideMask /t REG_DWORD /d 3 /f

    and restart the computer, then my cpu performs roughly 3% slower in CPUZ/CBR20/CBR23 benchmarks, both MT and ST, and random reboots begin to appear (I normally have both Cool'n'Quiet and SoC/Uncore OC options in my BIOS set to enabled, without any issue, but if I apply the above registry keys changes then the pc begins to randomly reboot until I disable those two settings in the BIOS).

    If I disable the Speculative Store Bypass mitigation (but keep the Spectre Variant 2 mitigation), using the following commands from a Powershell (Administrator):
    reg add "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Contr ol\Session Manager\Memory Management" /v FeatureSettingsOverride /t REG_DWORD /d 0 /f
    reg add "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Contr ol\Session Manager\Memory Management" /v FeatureSettingsOverrideMask /t REG_DWORD /d 3 /f

    and restart the computer, my 3% of benchmark scores are back and I can safely enable both Cool'n'Quiet (named PSS Support in the asus BIOS) and SoC/Uncore OC in the BIOS and have no random reboots.

    I am using AGESA 1.1.9.0 but imho it is not related. Your mileage may vary, as Windows Update may or may not have automatically enabled this mitigation on your Windows install, so someone else may want to check this. A few other users confirmed the same on reddit, so I thought this may have been useful to share here.

  2. #2
    ROG Enthusiast Array Sigtran PC Specs
    Sigtran PC Specs
    MotherboardAsus Crosshair VI Hero
    ProcessorRyzen 9 3900x
    Memory (part number)F4-3200C14D-16GVK @ 3600MHz
    Graphics Card #1Gigabyte GTX1080ti Gaming OC
    Monitor27" Lenovo Legion Y27q-20, WQHD 165Hz IPS
    Storage #1Samsung 970 EVO Plus 1TB
    Storage #2Samsung 860 EVO 1TB
    CPU CoolerNoctua NH-D14
    CaseCoolerMaster 690
    Power SupplyCorsair HX1000i
    Keyboard Dell SK-8115
    Mouse Logitech G305
    Headset/Speakers Logitech X-540
    OS Win10 X64 Home
    Network RouterAC2600
    Accessory #1 Logitech C930e webcam
    Sigtran's Avatar
    Join Date
    Sep 2017
    Reputation
    28
    Posts
    72

    Thanks for sharing.

    My guess is that ~3% slowdown would be a negative side effect of the "fix" and probably no much chance to be avoided in the future for current CPUs. I've seen on some sites even ~4% slowdown on average, for example here:
    https://www.phoronix.com/scan.php?pa...-spectre&num=1

    Regarding random reboots, this should of course not happen and it would be good if checked on some other, non-Asus motherboards.

    1) If with other motherboards with same AGESA these random reboots do not happen, then it is most likely due to a bug in Asus BIOS.

    2) If it happen with others motherboards with same AGESA but not with different AGESA, then it is up to AMD to fix the bug, and Asus to implement it in new BIOS.

    3) If it happens with everyone, then it is AMD and/or MS to blame for issuing a very bad fix, but this is a bit unlikely.
    Last edited by Sigtran; 01-09-2021 at 08:02 AM.

  3. #3
    ROG Enthusiast Array
    Join Date
    Jan 2019
    Reputation
    55
    Posts
    60

    I agree with what you said. Some people on reddit also pointed out that disabling this mitigation fixed their high temperatures at idle, and I confirm that temperatures are lower during normal use with this mitigation disabled, so I guess there is definitely something misbehaving here, in the microcode or how Windows leverages it to mitigate the vulnerability.

    For the reboots at idle you can quickly check on your rig if you are interested, enable the mitigation and use it normally and you will not get 30 minutes before a random reboot happens.
    Last edited by Kelutrel; 01-09-2021 at 11:42 AM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •