Results 1 to 1 of 1
  1. #1
    New ROGer Array
    Join Date
    Feb 2019

    Please Help Bios Failier B450-F AMD 5 2600

    I built my computer a year ago and it worked (I know if it aint broke). Last night I decided to update the bios from Ver 1201 to Ver 4007 and in the middle of the flash our electricity flickered and the computer rebooted before it was done. The reason I was updating is it was getting to freeze and the power off on switch would not work when the screen froze.

    Motheboard: B450-F
    CPU: AMD 5 2600
    Memory G-skill TridentZ RGB
    Graphics card: Gigabyte GTX 1600TI

    When I start the computer it does not post, I have taken the ram out and reinstalled, same for the graphics card. I have unplugged the computer and taken the battery out and shorted the CMOS still no post. I get a yellow Ram light for a second then the RED CPU light.

    I have tried ASUS CrashFree BIOS 3 but it will not boot from the USB.

    How do I know if I have bricked my motherboard or damaged my CPU or both?
    Last edited by Handcd; 01-12-2021 at 03:52 AM.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts