Results 1 to 5 of 5
  1. #1
    New ROGer Array
    Join Date
    Jun 2020
    Reputation
    10
    Posts
    1

    Armoury Crate needs higher privilegs

    Hello Guys,

    this is a bit frustrating since i setup computers with different right shemas. Since day one in computer area its common use to split roles by user rights. Thats why all my users get regular "USER" rights nothing more. Now the issue with Armoury Crate is the missing "RUN AS ADMINISTRATOR" function within the APP. Armoury Crate moved to Windows 10 APPs which has no rhich ".exe" to start with.

    I have tested this with an regular administrator account and Armoury Crate works flawlessly as well as other ASUS Suite Software like AI Suite 3. AI Suite 3 can be prompted by Admin Account which doesnt work at all with Windows 10 APP of Armoury Crate.

    I dont know if this is the new "Design" and "RISK" Scenario to tell people using a Admin Account for the daily use. I wont reccomend this at all at any time.

    So whats the proper solution? Currently i am logging into a local admin account and make my settings to the devices controllable through Armoury Crate. Then logging back into the regular user for using the desktop. This is not in any kind a tolerable solution.

  2. #2
    ROG Member Array
    Join Date
    Mar 2019
    Reputation
    10
    Posts
    8

    I have this same issue. When logged into the admin account everything works as it should. When I log in as a regular user options are severly limited. The most bizzare thing is that the RYOU section will recognize a MSI video card and NOTHING made by ASUS.

    Give us the option to "Run as Admin" so our settings work like they do when logged in as an admin.

    Helpful hint. If you do add "Run as Admin" then REMOVE this access when the program is closed. Problem solved.

  3. #3
    ROG Member Array
    Join Date
    Oct 2015
    Reputation
    10
    Posts
    8

    Yup, same problem. I already created a thread about this months ago: https://rog.asus.com/forum/showthread.php?124289

    Unfortunately ASUS seems to not care about this problem at all since no response has been made. I guess after ASUS has successfully sold you their product the support ends there and you're on your own. At least that's how I feel as a paid customer. It's a shame that the product itself works great but the software is at some broken alpha build stage atm.

  4. #4
    ROG Junior Member Array
    Join Date
    Dec 2013
    Reputation
    10
    Posts
    2

    I yet to get htis to work admin or not.

    It installs but won't run.

  5. #5
    ROG Guru: Orange Belt Array ahfoo's Avatar
    Join Date
    Jan 2020
    Reputation
    36
    Posts
    267

    Quote Originally Posted by Knight Trane View Post
    It installs but won't run.
    It appear conflicting with 3rd party software.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •