Results 1 to 2 of 2
  1. #1
    New ROGer Array
    Join Date
    Oct 2020

    Exclamation ASUS STRIX SOAR WINDOWS 10 20H2 (build 19042.746)

    I had the soundcard running fine and flawless till the update in October made the card broken and forcing some other driver from windows to run it without enabling any of the features. I went through as many fixes and threads looking for help and creating this one if this gets some response at least from moderators or ASUS themselves.

    Then the soundcard would never install period saying it was denied by windows so I was on onboard sound for a while till the 1.1.22 came out. Which when I managed to get windows to recognise the card I installed and it worked, till I rebooted. And was back again at no soundcard or rapid clicking till a shutdown was needed.

    I even went through the trouble of reformatting the pc with a 20H2 image and it still refuses to work from cold boot or rebooting.

    I still get either rapid relay clicks that never stops, have to shutdown the pc completely or it does again on next reboot or a couple then when in Windows 10 there is no sound card detected and have to use onboard reltek. I have the 1.1.22 drivers installed.

    Now after any random amount of time the soundcard will be finally recognised and when I say random I am talking 30mins to sometime the next day or 2. And always happens when I am gaming. Never on desktop use.

    I can pass along my dxdiag file to anyone at ASUS for help in getting this to finally work.

  2. #2
    ROG Member Array
    Join Date
    Aug 2020

    I dont think ASUS care

    I and a couple of others in this forum have the same problem. I have an ongoing ticket with them and they have never acknowledged the problem but have offered me a buy back option, I've filled all the forms out and emailed them but have no acknowledgement that they recieved them other then before I emailed them they did say there was no point in sending the card to them due to no one being in the office due to the lockdown.

    I firmly believe that the firmware on the card is now nolonger compatable with 20H2, I've given up on the card and running on the onboard soundcard.
    Like you my card can take up to an hour to be detected, this is definitely a Asus problem but going on how long it took them to acknowledge the digital licence problem and fixing it I wouldn't hold your breath.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts