Results 1 to 2 of 2
  1. #1
    ROG Member Array geecee61 PC Specs
    geecee61 PC Specs
    MotherboardAsus Strix Z490 F
    ProcessorIntel Core i7-10700K
    Memory (part number)Corsair Vengeance RGB PRO 3600 32GB
    Graphics Card #1ASUS GeForce GTX 1080TI 11GB ROG STRIX
    Sound CardAsus Strix Raid DLX 7.1 Soundcard
    Storage #1Samsung M.2 NVMe SSD 970 evo 1TB
    Storage #2WD Blue 3D NAND 500GB SSD
    CPU CoolerCooler Master MAZ-T8PN CPU cooler
    CasePhanteks Enthoo Pro TG
    Power SupplyASUS The ROG Strix 750 W Gold
    Keyboard Asus Rog Strix Flare
    Mouse Asus ROG Pugio
    Headset ASUS Cerberus V2
    Mouse Pad ASUS ROG Sheath
    Headset/Speakers Creative Inspire T6300 5.1 PC Speakers
    OS Windows 10 Pro 64 bit
    Network RouterVirgin Super Hub
    Accessory #1 Asus ROG Front Base Control Panel

    Join Date
    Nov 2017

    Strix Soar sound card issue

    I recently upgraded from a Strix Z270 to a Z490 F with an i7 10700K and a Rog 750 PSU, I put my Nvme in and all works ok except the Strix Soar sound card didn't show up, I have tried it in different PCIe slots and it sometimes works and shows in device manager but the minute I reboot is disappears and is grey out and can only be seen in hidden devices, I have tried uninstalling the software after removing the card and reseating it but then it doesn't even show in hidden devices and I have to just keep trying different lanes multiple times before it suddenly shows up again only to disappear after I reinstall the software and have to restart my computer, I restested the card on my other computer and it seems to work fine, can anyone shed some light on this and prehaps solve this for me, also since the upgrade after a reboot things like webpages and apps load slower
    Miniatura de Adjuntos Miniatura de Adjuntos ScreenHunter 3223.jpg  

    Last edited by geecee61; 02-12-2021 at 01:24 PM.

  2. #2
    ROG Member Array
    Join Date
    Aug 2020

    Asus don't care

    Sounds like you're having a similar problem as people with soundcards not being detected, just look at the posts below.
    Asus are not even admitting there is a problem, my card (Strix Raid pro) takes nearly an an hour to get detected so is unuseable, imho I think it's a firmware problem which is now incompatable with Windows 20H2.
    I have a ticket open with Asus and their only advice is they might do a a buy back.

    Anyway good luck.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts